Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1969765

Summary: [CBT] Failed to redefine VM checkpoints for full backup that was taken after previous incremental backup
Product: [oVirt] ovirt-engine Reporter: Eyal Shenitzky <eshenitz>
Component: BLL.StorageAssignee: Eyal Shenitzky <eshenitz>
Status: CLOSED CURRENTRELEASE QA Contact: Amit Sharir <asharir>
Severity: high Docs Contact:
Priority: unspecified    
Version: 4.4.7CC: bugs, dfodor, sfishbai
Target Milestone: ovirt-4.4.7Keywords: ZStream
Target Release: ---Flags: pm-rhel: ovirt-4.4+
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-07-06 07:28:01 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Storage RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Eyal Shenitzky 2021-06-09 08:43:48 UTC
Description of problem:

In an environment with cluster level lower than 4.6, VM checkpoint redefinition can fail due to the removal of the parent ID from the checkpoint XML in Libvirt.

The cause for that failure is that now when the parent checkpoint ID removed from the XML, when fetching the defined checkpoint list with VIR_DOMAIN_CHECKPOINT_LIST_TOPOLOGICAL flag, the order of the defined checkpoints doesn't match the order of the checkpoints in the engine DB.


Version-Release number of selected component (if applicable):
4.4.7

How reproducible:
100%

Steps to Reproduce:
1. Create a cluster level with version < 4.6
2. Create a VM with disk enabled for backup
3. Start a full and incremental backup when the VM is down
4. Start the VM
5. Start a full backup when the VM is up.
6  Start an incremental backup using the checkpoint from step 5 when the VM is up ==> Checkpoint redefinition failed.

Actual results:
Checkpoint redefinition failed.

Expected results:
Checkpoint redefinition should succeed.

Additional info:

Comment 1 Amit Sharir 2021-06-22 14:35:46 UTC
Version for verification: 
ovirt-engine-4.4.7.4-0.9.el8ev.noarch
rhv-release-4.4.7-4-001.noarch
redhat-release-8.4-0.6.el8.x86_64
redhat-release-eula-8.4-0.6.el8.x86_64

Verification conclusions:
The expected output matched the actual output. 
I used a cluster of version 4.5.
The total flow Eyal (steps 1-6) mentioned was done with no errors/unexpected logs - I was able to complete successfully all the backups.
I also checked the log and verified that the log contained a message that the VM checkpoint redefinition succeeded. 

Bug verified.

Comment 2 Sandro Bonazzola 2021-07-06 07:28:01 UTC
This bugzilla is included in oVirt 4.4.7 release, published on July 6th 2021.

Since the problem described in this bug report should be resolved in oVirt 4.4.7 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.