Bug 196983 - kernel 2.6.17-1.2139_FC4 missing lib/module sk98lin
kernel 2.6.17-1.2139_FC4 missing lib/module sk98lin
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-27 19:05 EDT by Philip Goisman
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-05 14:18:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
paths to kernel files/modules (9.30 KB, application/octet-stream)
2006-07-05 13:33 EDT, Philip Goisman
no flags Details

  None (edit)
Description Philip Goisman 2006-06-27 19:05:35 EDT
Description of problem:sk98lin lib/module does not exist in latest kernel - 
2.6.17-1.2139_FC4.  This stops eth0 from connecting/initiation.  Error message
is, "sk98lin device eth0 does not seem to be present delaying initiation."
Version-Release number of selected component (if applicable):
2.6.17-1.2139_FC4

How reproducible:
boot with kernel 2.6.17-1.2139_FC4 using the ethernet card that relies on the
module sk98lin

Steps to Reproduce:
1.boot using 2.6.17-1.2139_FC4
2.
3.
  
Actual results:
no network connection.  Error message as stated above.

Expected results:
network connection

Additional info:
Comment 1 Anonymous Coward 2006-07-05 11:21:14 EDT
sk98lin has been replaced with skge
Comment 2 Philip Goisman 2006-07-05 13:33:42 EDT
Created attachment 131949 [details]
paths to kernel files/modules 

if skge is to replace sk98lin, why doesn't it provide the network connection?
Comment 3 John W. Linville 2006-07-05 13:50:53 EDT
Edit /etc/modules.conf, replacing all instances of "sk98lin" with "skge".  
Then, reboot.  Does that help?
Comment 4 Philip Goisman 2006-07-05 14:14:13 EDT
(In reply to comment #3)
> Edit /etc/modules.conf, replacing all instances of "sk98lin" with "skge".  
> Then, reboot.  Does that help?

The file I edited on my FC4 system is /etc/modprobe.conf.  That worked.
Thanks and sorry I didn't pick up on this in comment#1.
Comment 5 John W. Linville 2006-07-05 14:18:12 EDT
Yes, forgive my typo.  It sounds like you have things working.

I'm going to call this WONTFIX since it is really an sk98lin problem, and that 
driver basically is unsupported upstream.

Note You need to log in before you can comment on or make changes to this bug.