This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 196990 - Thinkpad T23: under recent kernels, middle mouse button stops working after hibernate to disk
Thinkpad T23: under recent kernels, middle mouse button stops working after h...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-27 20:16 EDT by Mark Alford
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-01 15:02:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Alford 2006-06-27 20:16:04 EDT
Thinkpad T23: middle mouse button stops working when I revive the computer after
a hibernate to disk.

This occurs in kernel-2.6.16-1.2108_FC4, kernel-2.6.16-1.2111_FC4, and
kernel-2.6.16-1.2115_FC4. It does NOT occur in kernel-2.6.13-1.1532_FC4.

It occurs even in text console mode (eg after typing CTRL+ALT+F1 to get a text
login screen) so I don't think it is an X problem.

If I do xev then the middle mouse button does not produce any event.
Comment 1 Mark Alford 2006-07-02 17:33:56 EDT
Update: if I boot with the selinux=0 kernel option, the problem goes away. Does
that mean it should be recharacterized as a SELinux bug?
Comment 2 Mark Alford 2006-08-01 15:02:38 EDT
OK, it turns out that selinux=0 didn't really fix the problem. 

What seems to have fixed it is changing a BIOS setting. In the BIOS menu, Config
-> Keyboard/Mouse -> Trackpoint, change the setting from [AutoDisable] to
[Enabled]. The bizarre thing is that when I later changed the setting back to
[AutoDisable], the problem didn't come back.

Note You need to log in before you can comment on or make changes to this bug.