Bug 1970140 - DNS SRV request which worked in 4.7.9 stopped working in 4.7.11
Summary: DNS SRV request which worked in 4.7.9 stopped working in 4.7.11
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.6
Hardware: All
OS: All
high
urgent
Target Milestone: ---
: 4.6.z
Assignee: Stephen Greene
QA Contact: Hongan Li
URL:
Whiteboard:
Depends On: 1967766
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-06-09 21:33 UTC by OpenShift BugZilla Robot
Modified: 2022-08-04 22:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The fix for Bug 1953097 enabled the CoreDNS Bufsize plugin with a size of 1232 bytes. Some primitive DNS resolvers are not capable of receiving DNS response messages over UDP that are greater than 512 bytes. Note that DNS resolvers that retry lookups using TCP (such as Dig) are not affected by this bug. Consequence: Some DNS resolvers (such as Go's internal DNS library) are unable to receive long-winded DNS responses from openshift-dns. Fix: Set the CoreDNS bufsize to 512 bytes for all servers. Result: DNS Clients that require UDP DNS messages to not exceed 512 bytes function as expected.
Clone Of:
Environment:
Last Closed: 2021-06-22 08:29:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-dns-operator pull 279 0 None open [release-4.6] Bug 1970140: Corefile: Set bufsize to 512 bytes for all servers 2021-06-10 13:13:16 UTC
Red Hat Product Errata RHBA-2021:2410 0 None None None 2021-06-22 08:30:12 UTC

Comment 2 Hongan Li 2021-06-11 09:21:35 UTC
verified with 4.6.0-0.nightly-2021-06-10-234022 and passed.

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2021-06-10-234022   True        False         35m     Cluster version is 4.6.0-0.nightly-2021-06-10-234022

$ oc -n openshift-dns get cm/dns-default -oyaml
apiVersion: v1
data:
  Corefile: |
    # test
    mytest.ocp:5353 {
        forward . 192.168.1.2
        errors
        bufsize 512
    }
    .:5353 {
        bufsize 512
        errors
        health {
            lameduck 20s
        }
        ready

Comment 5 errata-xmlrpc 2021-06-22 08:29:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.35 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:2410


Note You need to log in before you can comment on or make changes to this bug.