Bug 197035 - gdm themes use specific hardcoded font names
gdm themes use specific hardcoded font names
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-artwork (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 199279 (view as bug list)
Depends On:
Blocks: FC6Desktop
  Show dependency treegraph
 
Reported: 2006-06-28 04:14 EDT by Dimitris
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-19 00:24:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dimitris 2006-06-28 04:14:52 EDT
Description of problem:

When installing FC6-test1 using different languages, like for example Greek, the
entire system uses that selected language. While it works fine everywhere else,
gdm has problems displaying the language correctly.

Apparently, the gdm themes use hardcoded font names, specifically they use
"Bitstream Vera Sans" along with variands (bold, different font size etc).

Since Bitstream Vera doesn't support all available language characters it forces
the system to do substitution, thus the overal effect is ugly looking characters.

We propose, to use generic family names, like "Sans". This way, gdm will use the
correct Sans family font thats good for the selected language and not force
Bitstream Vera and font substitution.

Also see:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=170218#c77
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=170218#c79


Version-Release number of selected component (if applicable):

FC6-test1


How reproducible:

Always


Steps to Reproduce:
1. install FC6-test1 and select Greek in the language selection
2. complete the installation and reboot
3. install proper Greek fonts like Dejavu (from extras)
4. confirm that the entire system uses Dejavu fonts and Greek displays fine
while gdm looks ugly with all fonts messed up because it enforces Bitstream fonts.

  
Actual results:

The proper font isn't beign used, thus fonts look messed up.


Expected results:

Correct font is selected and characters look as the should.


Additional info:

none.
Comment 1 Rahul Sundaram 2006-07-20 15:34:39 EDT
Adding this bug to the FC6 Desktop blocker tracker. 
Comment 2 Ray Strode [halfline] 2006-07-21 15:47:10 EDT
*** Bug 199279 has been marked as a duplicate of this bug. ***
Comment 3 Ray Strode [halfline] 2006-07-21 15:49:00 EDT
We've decided to go with DejaVu by default.  This bug has been worked around
temporarily, by making requests for "Bitstream Vera" return DejaVu.

We should get the theme updated though.
Comment 4 Dimitris 2006-07-23 18:18:54 EDT
Once the theme is updated it will work correctly for everyone, no matter what
kind of fonts/languages they use.

Thank you.
Comment 5 Matthias Clasen 2006-07-26 21:22:40 EDT
Fixed in redhat-artwork-0.245-1. Ray needs to rebase the RHEL-5 branch to that 
version, and move his patchwork upstream.
Comment 6 Matthias Clasen 2006-08-19 00:24:50 EDT
Done in 5.0.2-1.el5
Comment 7 Dimitris 2006-08-27 09:17:12 EDT
Thank you!

Note You need to log in before you can comment on or make changes to this bug.