Bug 197040 - qt4: -static package
qt4: -static package
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: qt4 (Show other bugs)
5
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-28 05:03 EDT by Adrien Bustany
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-01 10:38:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrien Bustany 2006-06-28 05:03:53 EDT
Description of problem:
It would be nice to have a qt4-static package, so that you can produce
statically linked apps just by adding the 'static' keyword in the project file.
This would be useful because qt4 is not that widespread today among linux
distributions.
Comment 1 Rex Dieter 2006-06-28 07:37:26 EDT
I have to be honest, this is less than likely.  Fedora Packaging standards
strongly discourage packaging/using static libs.
Comment 2 Adrien Bustany 2006-06-28 07:41:55 EDT
Are Fedora people aware that we develop software not only for Fedora users ? I'm
OK for not using static libs in fedora packages, but providing it for
development would be useful...
Anyway, thanks for your answer and your work on qt4 :)
Comment 3 Rex Dieter 2006-08-01 10:38:46 EDT
Static linking just isn't possible, without a reverse of policy in Packaging 
Guidelines, and without support for static linking from all dependant 
libraries, including (at least): zlib, glib2, dbus, nas, fontconfig, freetype, 
libjpeg, libmng, libpng (and X?).  Neither of these prereq's are likely to 
happen in Fedora soon (if ever).

Note You need to log in before you can comment on or make changes to this bug.