Bug 1970485 - Add pipeline annotation to Secrets which are created for a private repo
Summary: Add pipeline annotation to Secrets which are created for a private repo
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.7.z
Assignee: Mohammed Saud
QA Contact: spathak@redhat.com
Rishu Mehra
URL:
Whiteboard:
Depends On: 1970470
Blocks: 1970984
TreeView+ depends on / blocked
 
Reported: 2021-06-10 14:45 UTC by Mohammed Saud
Modified: 2021-07-07 20:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, *Pipelines* you created in the git import flow for private repos failed to run. This happened because *Pipeline* ServiceAccount did not use secrets created by git import flow for private git repositories. With this update, you can add a secret name to the pipeline ServiceAccount's annotations, and add pipeline-specific annotations to the provided secret. As a result, pipelines for private git repositories run successfully. (link:https://bugzilla.redhat.com/show_bug.cgi?id=1970485[BZ#1970485])
Clone Of: 1970470
: 1970984 (view as bug list)
Environment:
Last Closed: 2021-06-29 04:20:23 UTC
Target Upstream Version:


Attachments (Terms of Use)
Pipeline annotation works for Secrets which are created for a private repo (34.40 KB, image/png)
2021-06-16 07:30 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 9207 0 None open [release-4.7] Bug 1970485: Add pipeline annotation to secrets for private git repo import with pipeline 2021-06-10 14:56:15 UTC
Red Hat Product Errata RHBA-2021:2502 0 None None None 2021-06-29 04:20:39 UTC

Description Mohammed Saud 2021-06-10 14:45:11 UTC
+++ This bug was initially created as a clone of Bug #1970470 +++

Description of problem:
Pipeline created as part of git import flow do not work for private git repositories.

How reproducible:
Always

Steps to Reproduce:
Create deployment from a private git repo, and check the add pipeline option.

Actual results:
Pipeline fails to run, as it does not use the git secret provided.

Expected results:
Pipeline should run successfully, using the secret.

Comment 3 spathak@redhat.com 2021-06-16 07:30:54 UTC
Created attachment 1791471 [details]
Pipeline annotation works for Secrets which are created for a private repo

Comment 4 spathak@redhat.com 2021-06-16 07:32:11 UTC
Verified on build version: 4.7.0-0.nightly-2021-06-12-151209
Browser: Google Chrome 89

Comment 5 OpenShift Automated Release Tooling 2021-06-17 12:29:08 UTC
OpenShift engineering has decided to not ship Red Hat OpenShift Container Platform 4.7.17 due a regression https://bugzilla.redhat.com/show_bug.cgi?id=1973006. All the fixes which were part of 4.7.17 will be now part of 4.7.18 and planned to be available in candidate channel on June 23 2021 and in fast channel on June 28th.

Comment 9 errata-xmlrpc 2021-06-29 04:20:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.18 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:2502

Comment 10 Rishu Mehra 2021-07-07 07:24:23 UTC
This issue is fixed in https://bugzilla.redhat.com/show_bug.cgi?id=1970470
So no need to document this one. The "Doc Text" field is not required in this one.


Note You need to log in before you can comment on or make changes to this bug.