Bug 19705 - redials after disconnect
redials after disconnect
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-24 14:44 EDT by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-13 05:25:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-24 14:44:52 EDT
When using redhat dialer, it dials correctly but after hangup it redials.  I just upgraded from 6.2 to 7.0.  It worked fine in 6.2
Comment 1 Need Real Name 2000-10-25 17:01:26 EDT
I also have this problem. I had to "downgrade" back to 6.2 to use my system.
This is a serious problem in that 
it is imposible to use 7.0 if you need PPP. In my case I was able to get the
"debug" button from the dial-up PPP
suite to dial and hook up, but then I could not get FTP to work. (SEE Red Hat
Service Request #160532, and
ask Jeff about this.) Please increase the severity and priority of this bug.

thanks,
-vince 
vincentc@erols.com
(703)440-3692
Comment 2 Richard Smith 2000-11-07 12:40:18 EST
For me, this problem does not occur if I disconnect using the small round
disconnect button on the applet, it only occurs if I attempt to disconnect
during the dialing process using the 'cancel' button.

I think Vince is talking about a completely different bug, because a redialing
modem hardly makes the system unusable (just pull the modem out of the socket,
or kill the ppp process).

Still, it was possible to halt the dialling process in 6.2, and it isnt in 7.0,
and it ought to be fixed.
Comment 3 Martijn Kruithof 2000-11-12 16:48:21 EST
I tried to take down ppp0 for security reasons today, but ppp0 was re-
established automagically. I tried to take ppp0 down by typing ifdown ppp0
as root

Further analysis showed that the ifdown-ppp and ifup-ppp scripts are not 
aligned:

ifup-ppp checks on "${DEMAND}" != yes and ${DEMAND} = yes 
ifdown-ppp checks on "${DEMAND}" != no

Examining ifcfg-ppp0 DEMAND is not present. This will lead to the behaviour 
described, when ifdown-ppp is changed to check on ${DEMAND} = yes everything 
works: therefore the following patch solves the problem:

--- ifdown-ppp.redhatorig      Sun Nov 12 22:33:16 2000
+++ ifdown-ppp  Sun Nov 12 22:33:34 2000
@@ -7,7 +7,7 @@
 CONFIG=$1
 source_config

-if [ "${DEMAND}" != no -a -f /var/run/ppp-${DEVICE}.pid ] ; then
+if [ "${DEMAND}" = yes -a -f /var/run/ppp-${DEVICE}.pid ] ; then
     PID=`head -1 /var/run/ppp-${DEVICE}.pid`
     kill -TERM ${PID}
     sleep 2

I guess this one is solved

Kind Regards, Martijn Kruithof
Comment 4 Doug Campbell 2000-11-30 00:39:48 EST
I have the same problem.  Apparently, the command "ifdown ppp0" does not
terminate the ppp-watch program, which is monitoring and automatically restarts
ppp if it sees the connection go down.  My workaround is to do a ps, locate the
ppp-watch program, and kill it.  After killing ppp-watch, ifdown ppp0 will work
properly.  The problem is likely in the
/etc/sysconfig/network-scripts/ifdown-ppp script; it should do the reverse of
the ifup-ppp script in the same directory (but doesn't).
Comment 5 Richard Smith 2000-11-30 17:00:10 EST
Doug, did Martijn's patch not work for you?  It just seems a little strange to
hear you saying that ifdown-ppp doesnt work, when immediately above your comment
is a patch which fixed it perfectly for me.
Comment 6 Doug Campbell 2000-12-03 01:59:02 EST
Martijn's
Comment 7 Doug Campbell 2000-12-03 02:05:38 EST
I did not notice Martijn's comment before posting my own (browser operator error
-- failure to scroll comments completely before going to bottom to add own).  It
looks like it'll work.  Another fix for those who prefer to wait for RedHat to
service the problems (or who don't want the auto-restart at all)is to go into
/etc/sysconfig/network-scripts and edit the ifcfg-ppp scripts to set PERSIST to
no.

As for me, I disabled the ppp scripts this morning because I just got DSL.
Comment 8 Thomas Woerner 2004-08-13 05:25:55 EDT
Please verify this with a newer version of Red Hat Enterprise Linux or Fedora
Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.

Note You need to log in before you can comment on or make changes to this bug.