Bug 197059 - "Could not link pipeline" error with WAV output
"Could not link pipeline" error with WAV output
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: sound-juicer (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-28 07:53 EDT by Tim Waugh
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.16.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-19 11:00:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes extraction to default WAV profile (already in 2.16.1) (880 bytes, patch)
2006-10-25 14:43 EDT, John Thacker
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 168508 None None None Never

  None (edit)
Description Tim Waugh 2006-06-28 07:53:15 EDT
Description of problem:
With the output setting set to 'Voice, lossless (WAV)', I can't extract any CD
tracks.  I get this error:

Sound Juicer could not extract this CD.
Reason: Could not link pipeline

Version-Release number of selected component (if applicable):
sound-juicer-2.14.4-1.fc5.1

How reproducible:
100%

Steps to Reproduce:
1. Select 'Voice, lossless (WAV)' for the output setting
2. Try to extract an audio track
  
Actual results:
Fails

Expected results:
Works

Additional info:
Selecting 'CD quality, lossless (FLAC)' works fine (but I wanted WAV files..).
Comment 1 Nicola Soranzo 2006-10-20 11:37:31 EDT
Same problem here. Is someone working on it?
Comment 2 John Thacker 2006-10-25 14:40:20 EDT
Almost surely this upstream bug--
http://bugzilla.gnome.org/show_bug.cgi?id=168508

Scroll down a bit.  Also note the link to a Ubuntu bug:
"Ubuntu https://launchpad.net/distros/ubuntu/+source/sound-juicer/+bug/38428 is
about that too:

"Using dapper, Notebook Panasonic Cf-Y4 (sound : intel ICH6)
Trying ripping CD, the following error is displayed.

Sound Juicer could not extract this CD
Reason: Failed to link pipeline.

This problem happens only if I select wav in the preferences,
Ogg and Flac seem working.

Strangely works if launch
gnome-audio-profiles-properties
select wav item
change
audio/x-raw-int,rate=22050,channels=1 ! wavenc name=enc
in
audio/x-raw-int,rate=44100,channels=1 ! wavenc name=enc"

Should be fixed upstream as of 2.16.1, which is in Rawhide but not FC6 yet.
There's a patch in the upstream bug.

Note that the default "lossless WAV" profile is technically mono 22khz audio,
not lossless CD quality stereo 44.1khz audio.
Comment 3 John Thacker 2006-10-25 14:43:53 EDT
Created attachment 139378 [details]
Fixes extraction to default WAV profile (already in 2.16.1)
Comment 4 John Thacker 2006-10-25 14:45:16 EDT
So if you want lossless CD quality WAVs (instead of voice quality WAVs), you'll
need to edit the audio profile or create a new one.

Anyway, it's not working because the default profile wants 22kHz samples, so
sound-juicer needs to add resampling to the pipeline in order to get it to work.
 I'll attach the patch which is in 2.16.1 that fixes it, but the real answer is
to simply upgrade to 2.16.1 like in RawHide.
Comment 5 John Thacker 2006-10-25 14:47:39 EDT
Reassigning to mclasen@redhat.com since (as far as I can tell), he's the one
that actually seems to own the component and make updates to the package.
Comment 6 Bastien Nocera 2007-04-19 11:00:34 EDT
The problem was fixed in sound-juicer 2.16.1 upstream, which is older than the
current version in FC6, or rawhide.

Closing as a stable release has the fix already.

Note You need to log in before you can comment on or make changes to this bug.