Bug 1970868 - [pulp3] aborting pulp3 content-migration step fails with "NoMethodError: undefined method fetch_from_list"
Summary: [pulp3] aborting pulp3 content-migration step fails with "NoMethodError: unde...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Foreman Maintain
Version: 6.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: 6.9.5
Assignee: Justin Sherrill
QA Contact: Devendra Singh
URL:
Whiteboard:
Depends On:
Blocks: 1957813
TreeView+ depends on / blocked
 
Reported: 2021-06-11 10:33 UTC by Matthias Dellweg
Modified: 2021-12-01 08:52 UTC (History)
8 users (show)

Fixed In Version: katello-3.18.1.36,tfm-rubygem-katello-3.18.1.37-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-31 12:03:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 32786 0 Normal New [pulp3] aborting pulp3 content-migration step fails with "NoMethodError: undefined method fetch_from_list" 2021-06-11 14:54:54 UTC
Red Hat Product Errata RHBA-2021:3385 0 None None None 2021-08-31 12:03:50 UTC

Description Matthias Dellweg 2021-06-11 10:33:30 UTC
Description of problem:
Aborting the pulp3 content-migration rake task via `satellite-maintain content prepare-abort`

Version-Release number of selected component (if applicable):
Katello 3.18.1

How reproducible:


Steps to Reproduce:
1. start the content migration step `satellite-maintain content prepare`
2. abort the content migration step `satellite-maintain content prepare-abort` from a different terminal
3.

Actual results:

Prepare content for Pulp 3:
Checking for valid Katello configuraton.
Starting task.
2021-06-10 14:54:21 +0000: Migrating rpm content to Pulp 3 5978/167886Migration failed, You will want to investigate: https://<redacted>/foreman_tasks/tasks/9026d986-1b11-41b4-96b1-642a5073bfbe
rake aborted!
ForemanTasks::TaskError: Task 9026d986-1b11-41b4-96b1-642a5073bfbe: NoMethodError: undefined method fetch_from_list' for #<Katello::Pulp3::Api::Core:0x000000001f7a7ed8>

/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.18.1.29/lib/katello/tasks/pulp3_migration.rake:35:inblock (2 levels) in '
/opt/rh/rh-ruby25/root/usr/share/gems/gems/rake-12.3.3/exe/rake:27:in `'
Tasks: TOP => katello:pulp3_migration
(See full trace by running task with --trace)
[FAIL]

Expected results:
The task will stop, and the rake command will exit cleanly telling so.

Additional info:

Comment 4 Justin Sherrill 2021-06-11 14:54:54 UTC
Created redmine issue https://projects.theforeman.org/issues/32786 from this bug

Comment 5 Bryan Kearney 2021-06-26 00:04:24 UTC
Moving this bug to POST for triage into Satellite since the upstream issue https://projects.theforeman.org/issues/32786 has been resolved.

Comment 6 Kenny Tordeurs 2021-08-16 09:20:20 UTC
*** Bug 1993682 has been marked as a duplicate of this bug. ***

Comment 7 Kenny Tordeurs 2021-08-16 09:21:31 UTC
Also consider adding a newline or whitespace for the failure:

~~~
2021-06-10 14:54:21 +0000: Migrating rpm content to Pulp 3 5978/167886Migration failed, You will want to investigate: https://<redacted>/foreman_tasks/tasks/9026d986-1b11-41b4-96b1-642a5073bfbe
                                                                     ^^^
~~~

Comment 15 Devendra Singh 2021-08-25 17:24:28 UTC
Verified on 6.9.5 Snap3.

Comment 18 errata-xmlrpc 2021-08-31 12:03:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Satellite Maintenance 6.9.5 Async Bug Fix Update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3385


Note You need to log in before you can comment on or make changes to this bug.