Bug 197115 - runTransaction doesn't dependency solve, which can break sync's to profiles on x86_64
runTransaction doesn't dependency solve, which can break sync's to profiles o...
Status: CLOSED DUPLICATE of bug 193563
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Beth Nackashi
:
Depends On: 193563
Blocks: 190430
  Show dependency treegraph
 
Reported: 2006-06-28 13:26 EDT by David Lehman
Modified: 2008-10-15 11:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-26 17:54:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lehman 2006-06-28 13:26:22 EDT
+++ This bug was initially created as a clone of Bug #193563 +++

runTransaction can be handed nvrea's, or just nvre's in the case of syncing to a
package profile.  With the fix for bz #162106, a box that has mixed 64bit &
32bit rpms will select 64bit packages as the "most desirable" during runTransaction.

Unfortunately, 32bit deps may still exist, and therefore the transaction will
fail w/ unmet dependencies.

Current plan is to do limited depsolving, so long as the results stay within the
the nvre universe of installed packages + delta (basically, don't go pulling in
new package names or version-release-epoch's that are outside of the defined
transaction).

Note that this will probably require a new server-side call to work correctly,
and will need to be tested against older satellite's to ensure backwards
compatibility...
Comment 1 James Bowes 2006-07-26 17:54:28 EDT

*** This bug has been marked as a duplicate of 193563 ***

Note You need to log in before you can comment on or make changes to this bug.