Bug 1971259 - Network map does not reflect changes to related network attachment definition
Summary: Network map does not reflect changes to related network attachment definition
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Migration Toolkit for Virtualization
Classification: Red Hat
Component: Controller
Version: 2.0.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 2.1.0
Assignee: Jeff Ortel
QA Contact: Maayan Hadasi
Avital Pinnick
URL:
Whiteboard:
Depends On:
Blocks: 1971321
TreeView+ depends on / blocked
 
Reported: 2021-06-13 08:47 UTC by Maayan Hadasi
Modified: 2021-08-26 07:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1971321 (view as bug list)
Environment:
Last Closed: 2021-08-26 07:09:10 UTC
Target Upstream Version:
istein: needinfo-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2021:3278 0 None None None 2021-08-26 07:09:18 UTC

Description Maayan Hadasi 2021-06-13 08:47:08 UTC
Description of problem:
The NetworkMap does not get updated in the following cases:
- When creating a NetworkAttachmentDefinition (NAD) for a second network after the NetworkMap already exists --> NetworkMap stays on "NotReady" state, message: "Destination network not found"
- When the NetworkMap is ready and you delete the NAD which is in use --> NetworkMap stays in "Ready" state


Version-Release number of selected component (if applicable):
mtv-operator-bundle-container-2.0.0-23


How reproducible:
100%


Steps to Reproduce:
1. Via API, create a NetworkMap CR that includes mapping to a second network (multus) --> NetworkMap is on "NotReady" state due to "Destination network not found"
2. Create a NetworkAttachmentDefinition CR for the second network


Actual results:
NetworkMap stays on "NotReady" state


Expected results:
NetworkMap moves to "Ready" state


Additional info:

Comment 1 Ilanit Stein 2021-06-13 14:01:52 UTC
@Avital,

For MTV-2.0,
Would you please document that the NetworkAttachmentDefinition CR creation for the second network, is a required step, 
BEFORE creating the network mapping, for the Migration, due to this bug?

Comment 4 Ilanit Stein 2021-06-13 15:32:46 UTC
Moving this bug back to a software bug, and cloning a doc bug instead.

Comment 5 Maayan Hadasi 2021-06-13 15:53:01 UTC
Hi @apinnick@redhat.com,

Regarding to this documentation page: https://access.redhat.com/documentation/en-us/migration_toolkit_for_virtualization/2.0/html-single/installing_and_using_the_migration_toolkit_for_virtualization/index?lb_target=stage

The "MTV custom resources" list contains also NetworkMapping and StorageMapping
But indeed in this section: "3.3. Migrating virtual machines from the command line interface" - there are no examples on how to create those CRs, and the example for Plan is an old solution where the mappings were internal
I will file a new Documentation BZs to update this section with NetworkMapping, StorageMapping and Plan CRs creation examples

Comment 6 Maayan Hadasi 2021-06-13 16:30:50 UTC
(In reply to Maayan Hadasi from comment #5)
> Hi @apinnick@redhat.com,
> 
> I will file new Documentation BZs to update this section with
> NetworkMapping, StorageMapping and Plan CRs creation examples

Bug 1971324 - [DOC][MTV][API] Add custom resource creation example for NetworkMap and StorageMap
Bug 1971326 - [DOC][MTV][API] Update custom resource creation example for Plan CR

Comment 7 Fabien Dupont 2021-06-14 09:08:51 UTC
@jorterl@redhat.com, do we need to add a watch for the NetworkAttachDefinition CRs?

Comment 8 Ilanit Stein 2021-06-15 09:52:28 UTC
Work around:

1. Delete the network mapping
2. Create the NAD
3. Recreate the network mapping

Comment 10 Jeff Ortel 2021-06-24 14:26:41 UTC
Found/Fixed the items listed on DestinationNetworkNotFound conditions.  No need to file a bug.
https://github.com/konveyor/forklift-controller/pull/293

Comment 11 Maayan Hadasi 2021-07-07 07:14:18 UTC
The issue is reproducible using mtv-operator-bundle-container-2.1.0-21

Comment 13 Fabien Dupont 2021-07-14 06:54:05 UTC
Please verify with build 2.1.0-29 / IIB:90663.

Comment 14 Maayan Hadasi 2021-08-11 12:24:55 UTC
Verified as fixed.

Versions:
MTV 2.1.0-44 iib 96817
CNV 4.8.1-17 iib 97584
OCP 4.8.4
(PSI)

Comment 17 errata-xmlrpc 2021-08-26 07:09:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Migration Toolkit for Virtualization 2.1.0), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2021:3278


Note You need to log in before you can comment on or make changes to this bug.