Bug 197129 - lang and langsupport ignored in kickstart configuration
lang and langsupport ignored in kickstart configuration
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-28 14:13 EDT by Brian Brock
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-20 14:34:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Brock 2006-06-28 14:13:29 EDT
A kickstart installation that includes directives for lang and langsupport
ignores th ks.cfg options in favor of prompting the user.

Seen in rawhide-20060628 with anaconda-11.1.0.48-1

The installation begins, boots the kernel grabbed via tftp, and proceeds until
the language configuration section.  I was expecting that section to continue
without prompting for user input.

in ks.cfg I specified:

install
nfs --server=<server> --dir=<dir>
lang en_US.UTF-8
langsupport --default=en_US.UTF-8 en_US.UTF-8
keyboard us
network --device eth0 --bootproto dhcp
Comment 1 Jeremy Katz 2006-06-28 14:22:11 EDT
I expect that the ks.cfg actually isn't being fetched because the kernel isn't
able to load modules right now... 
Comment 2 Chris Lumens 2006-06-28 14:37:14 EDT
Note that langsupport doesn't actually do anything anymore - you should see a
warning in your anaconda logs about that.
Comment 3 Chris Lumens 2006-07-13 14:57:24 EDT
Is this better now that the kernel can load modules again?
Comment 4 Brian Brock 2006-07-20 14:34:20 EDT
langsupport appears fine in recent trees, it's not stopping the installer.

closing rawhide

Note You need to log in before you can comment on or make changes to this bug.