Bug 1971443 - clang / libstdc++: missing typename when compiling with <ranges> and -std=c++2a
Summary: clang / libstdc++: missing typename when compiling with <ranges> and -std=c++2a
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1981085 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-06-14 05:58 UTC by Marián Konček
Modified: 2021-08-01 04:04 UTC (History)
11 users (show)

Fixed In Version: gcc-11.2.1-1.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-01 04:04:57 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNU Compiler Collection 100900 0 P3 RESOLVED error: missing 'typename' prior to dependent type name in <ranges> elements_view 2021-06-14 09:05:29 UTC

Description Marián Konček 2021-06-14 05:58:33 UTC
Compile the following file:
```
#include <ranges>
int main() {}
```

using:
$ clang++ -std=c++2a file.cpp

You will get an error:

/usr/lib/gcc/x86_64-redhat-linux/11/../../../../include/c++/11/ranges:3466:19: error: missing 'typename' prior to dependent type name 'iterator_traits<iterator_t<_Base>>::iterator_category'
            using _Cat = iterator_traits<iterator_t<_Base>>::iterator_category;

This renders clang unusable for any code that includes ranges and compiles with c++20 flags because clang hasn't implemented P0634R3.

The very simple fix is to add Fedora-speciffic patch which simply adds the typename into libstdc++.

Comment 1 Jonathan Wakely 2021-06-14 09:05:30 UTC
(In reply to Marián Konček from comment #0)
> The very simple fix is to add Fedora-speciffic patch which simply adds the
> typename into libstdc++.

No, because Fedora's policy is upstream first (and it's already fixed upstream).

Comment 2 Jonathan Wakely 2021-07-12 09:45:20 UTC
*** Bug 1981085 has been marked as a duplicate of this bug. ***

Comment 3 Avi Kivity 2021-07-18 10:10:09 UTC
The patch is now upstream, so a refresh of the Fedora package will bring it in.

Comment 4 Fedora Update System 2021-07-29 08:20:55 UTC
FEDORA-2021-32bc696c85 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-32bc696c85

Comment 5 Fedora Update System 2021-07-30 01:46:36 UTC
FEDORA-2021-32bc696c85 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-32bc696c85`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-32bc696c85

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2021-08-01 04:04:57 UTC
FEDORA-2021-32bc696c85 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.