RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1971697 - chrony-helper removes servers added in previous run
Summary: chrony-helper removes servers added in previous run
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: chrony
Version: 8.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: beta
: ---
Assignee: Miroslav Lichvar
QA Contact: Ondrej Mejzlik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-06-14 15:16 UTC by Miroslav Lichvar
Modified: 2021-11-10 09:31 UTC (History)
0 users

Fixed In Version: chrony-4.1-1.el8
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-09 19:51:57 UTC
Type: Bug
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2021:4462 0 None None None 2021-11-09 19:52:05 UTC

Description Miroslav Lichvar 2021-06-14 15:16:10 UTC
Description of problem:
NTP servers from DHCP added by the chrony-helper script are saved in /run/chrony-helper/added_servers. When the servers from DHCP are disabled (e.g. by setting PEERNTP=no in /etc/sysconfig/network) and the chronyd service is restarted, the script tries to remove those servers from the started instance, which can have them specified in chrony.conf.

Version-Release number of selected component (if applicable):
chrony-3.5-2.el8

How reproducible:
always

Steps to Reproduce:
1. configure DHCP to provide an NTP server
2. restart NetworkManager and chronyd
3. stop chronyd
4. add PEERNTP=no to /etc/sysconfig/network
5. add the server to chrony.conf
6. start chronyd
7. check if chronyd is using the server

Actual results:
server removed

Expected results:
server stays as configured

Additional info:

Comment 10 errata-xmlrpc 2021-11-09 19:51:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (chrony bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4462


Note You need to log in before you can comment on or make changes to this bug.