Bug 197188 - printouts are too small after cups upgrade
printouts are too small after cups upgrade
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-28 23:46 EDT by dann
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-13 04:46:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dann 2006-06-28 23:46:54 EDT
After upgrading from cups-1.1.23-30.2 to cups-1.2.1-1.2 printing from a windows
machine to an Apple LaserJet 16/600 PS network printer the printouts appear to
be scaled, they are too small and margins are about 2 inches.

The cups server is on a FC5 machine.
Printing from another FC5 machine works just fine. 

I turned off the printer and generated (almost) identical print jobs from both
windows and FC5 and looked in the spooler and saw thing fragment in the PS code
for the windows job:

%%BeginPageSetup
57.0 86.0 translate
4.0 0.0 translate 0.801 0.801 scale
0 0 translate
0 0 612 792 ESPrc
%%EndPageSetup

After deleting the 4 lines the job prints as expected. 

Everything works fine for cups-1.1.23-30.2. cups-1.2.1-1.7 has the same problem.
Comment 1 Tim Waugh 2006-06-29 04:56:12 EDT
Looks like the 'fitplot' option is set somewhere.  The system-config-printer
upgrade *ought* to have unset this option.  What does this command say?:

rpm -q system-config-printer

Also, please could you attach /etc/cups/lpoptions?  Thanks.
Comment 2 Jonathan Kamens 2006-08-21 22:18:36 EDT
I ran into a similar problem.  My /etc/cups/lpoptions hadn't been modified since
February 21, and nothing I did with the current system-config-printer would get
it to change.  Furthermore, the options listed in /etc/cups/lpoptions, which
included fitplot=true even though I never set that option explicitly with any
previous version of cups or system-config-printer, were not showing up anywhere
in the system-config-printer screens.

I solved the problem by emptying /etc/cups/lpoptions.
Comment 3 Jonathan Kamens 2006-08-21 22:20:31 EDT
jik2:~!2760$ rpm -q system-config-printer
system-config-printer-0.7.25-1

Here's what was in /etc/cups/lpoptions before I emptied it:

Dest color cpi=12 fitplot=true lpi=7 page-bottom=86 page-left=57 page-right=57
page-top=72 scaling=100 wrap=true
Dest color2 cpi=12 fitplot=true lpi=7 page-bottom=86 page-left=57 page-right=57
page-top=72 scaling=100 wrap=true
Dest draft cpi=12 fitplot=true lpi=7 page-bottom=18 page-left=18 page-right=18
page-top=18 scaling=100 wrap=true
Dest final cpi=12 fitplot=true lpi=7 page-bottom=86 page-left=57 page-right=57
page-top=72 scaling=100 wrap=true

As I mentioned, I couldn't see these options in system-config-printer, and
nothing I did there seemed to cause this file to be modified.
Comment 4 Tim Waugh 2006-11-13 04:46:16 EST
There are there, in the Queue Options tab.  It looks like somehow the
/usr/share/printconf/util/updateconf.py script didn't get run on upgrade.

Note You need to log in before you can comment on or make changes to this bug.