Bug 197199 - Yum cant run because of the background updates daemon.
Yum cant run because of the background updates daemon.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-29 03:03 EDT by Wade Mealing
Modified: 2014-01-21 17:54 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.9.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-29 11:03:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wade Mealing 2006-06-29 03:03:07 EDT
Description of problem:

Yum can not run sometimes because of the background downloader.


Version-Release number of selected component (if applicable):

[root@localhost ~]# rpm -qa | grep yum
yum-2.9.0-7
yum-metadata-parser-1.0-7

How reproducible:

A few times through out the day

Steps to Reproduce:
1. Use yum for daily use
2. Find that the yum-updatesd is locking the pid
3. Get annoyed, kill the pid that is holding the lockfile open
  
Actual results:

After killing the lock pid, yum works normally.


Expected results:

The interactive process should not be locked out, and I should be able to run
the yum command.
Comment 1 Jeremy Katz 2006-06-29 11:03:13 EDT
This should be fixed in yum 2.9.1

Note You need to log in before you can comment on or make changes to this bug.