Bug 197214 - better CJK text printing support
better CJK text printing support
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-29 07:12 EDT by Akira TAGOH
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-21 10:36:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
testcase (1.67 KB, text/plain)
2006-06-29 07:12 EDT, Akira TAGOH
no flags Details

  None (edit)
Description Akira TAGOH 2006-06-29 07:12:31 EDT
Description of problem:
right now CUPS doesn't work on CJK text printing at all. it has to be fixed
since this is an regression bug.

Version-Release number of selected component (if applicable):
cups-1.2.1-14.

How reproducible:
always

Steps to Reproduce:
1.lpr HELLO.utf8
2.
3.
  
Actual results:
unreadable characters are printed out.

Expected results:
should be printed out correctly

Additional info:
paps-0.6.6-8.fc6 that CUPS filter is enabled is now available. it may be a good
idea to replace texttops with paps. a filter name is texttopaps.
Comment 1 Akira TAGOH 2006-06-29 07:12:31 EDT
Created attachment 131739 [details]
testcase
Comment 2 Tim Waugh 2006-06-29 08:00:27 EDT
Built 1.2.1-15 with paps requirement and mime.convs modifications, so we'll see
how it works.
Comment 3 Akira TAGOH 2006-06-29 08:16:55 EDT
Thanks for quick update. this may be passive a bit though, but it may be still
better to use texttops for applications/* since paps doesn't support
"prettyprint" yet and it may be unlikely that any multibytes characters appears
in such MIME types. what do you think?
Comment 4 Tim Waugh 2006-06-29 10:39:09 EDT
Agreed.

I built paps-0.6.6-9 with a fix default font (it was trying to use "Monospace
DEFAULT_FONT_SIZE"..), and when I print HELLO.utf8 now I get lots of missing
symbols -- more than are missing when I 'cat' the file in gnome-terminal.

Missing characters for example:

Arabic
Cherokee
Georgian
Hebrew
IPA English
Maltese
Russian
Thai
Vietnamese
Yiddish

..and in particular, given what we're trying to achieve:

Japanese
Chinese
Cantonese
Korean

Any idea what we need to do to fix this?  Do we perhaps need paps to embed the font?
Comment 5 Akira TAGOH 2006-06-29 12:22:07 EDT
Oops, thanks for the fix.

Well, I'm not sure if it's output correctly since I'm not native for those
languages, but Arabic, Hebrew, IPA English, Maltese, Russian, Vietnamese,
Yiddish and CJK looks good as I can see on gedit say.
for Cherokee, Georgian and Thai, paps doesn't support the bitmap font to embed
the font. so no way to fix it ATM. and apparently we don't have any fonts for
Burmese and Sinhala.

To test HELLO.utf8, you may want to install the various font packages:
Arabic:      fonts-arabic
Bengali:     fonts-bengali
Gujarati:    fonts-gujarati
Hebrew:      fonts-hebrew
IPA English: urw-fonts
Maltese:     urw-fonts
Punjabi:     fonts-punjabi
Russian:     urw-fonts
Tamil:       fonts-tamil
Vietnamese:  urw-fonts
Yiddish:     fonts-hebrew
Chinese:     fonts-chinese
Japanese:    fonts-japanese
Korean:      fonts-korean
Comment 6 Akira TAGOH 2006-07-04 02:26:00 EDT
BTW how about describing the above into the relnotes say? it would be a good
idea to notice people which the font packages needs to be installed for the text
printing support for languages what one wants?
Comment 7 Tim Waugh 2006-07-04 06:22:35 EDT
Ah, all works fine now.  Thanks!

Yes, we could add something to the release notes about that.  I think, though,
that anaconda knows to install the relevant fonts during installation based on
the install language doesn't it?
Comment 8 Akira TAGOH 2006-07-04 06:57:29 EDT
Yes. I'm not so keen to describe it though, it may be still useful for people
who wants to get only the fonts installed since the language support will picks
up all the relevant packages for that language. just thoughts, but anyway.
Comment 9 Akira TAGOH 2006-07-21 10:33:28 EDT
can we close this bug now?

Note You need to log in before you can comment on or make changes to this bug.