Bug 1972183 - Backport enabling of pprof metrics for OpenShift SDN
Summary: Backport enabling of pprof metrics for OpenShift SDN
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.6.z
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
: 4.7.z
Assignee: cstabler
QA Contact: zhaozhanqi
URL:
Whiteboard:
Depends On: 1970497
Blocks: 1972587
TreeView+ depends on / blocked
 
Reported: 2021-06-15 12:02 UTC by Alexander Constantinescu
Modified: 2021-06-29 04:20 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1970497
: 1972587 (view as bug list)
Environment:
Last Closed: 2021-06-29 04:20:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-network-operator pull 1129 0 None open [release-4.7] Bug 1972183: config: Set enable-profiling true by default and allow enable-profiling as a proxy argument 2021-06-15 12:03:41 UTC
Red Hat Product Errata RHBA-2021:2502 0 None None None 2021-06-29 04:20:35 UTC

Description Alexander Constantinescu 2021-06-15 12:02:04 UTC
+++ This bug was initially created as a clone of Bug #1970497 +++

Description of problem:

Enable pprof by default for OpenShift SDN.

Enable by default in 4.8 via: https://github.com/openshift/cluster-network-operator/pull/988

Would aid in debugging without the need to scale down CVO / CNO and restart pods.

Version-Release number of selected component (if applicable):

4.6.x/4.7.x

How reproducible:
Always

Steps to Reproduce:
1. N/A

Actual results:

Not on by default

Expected results:


Additional info:

Can be enabled today via:

oc scale -n openshift-cluster-version deployments/cluster-version-operator --replicas 0

oc -n openshift-network-operator scale deployment/network-operator --replicas 0

oc -n openshift-sdn edit configmap sdn-config

Set: enableProfiling: true

Save and exit

Comment 2 zhaozhanqi 2021-06-17 07:38:53 UTC
Verified this bug on 4.7.0-0.nightly-2021-06-16-202127

$ oc get cm -n openshift-sdn sdn-config -o yaml | grep enableProfiling
    enableProfiling: true

Comment 5 errata-xmlrpc 2021-06-29 04:20:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.18 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:2502


Note You need to log in before you can comment on or make changes to this bug.