Bug 197230 - Broken upgrade path to -devel/FC6 for current cscope
Broken upgrade path to -devel/FC6 for current cscope
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cscope (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Neil Horman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-29 10:08 EDT by Jarod Wilson
Modified: 2013-01-09 22:58 EST (History)
1 user (show)

See Also:
Fixed In Version: 15.5-13.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-29 13:16:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jarod Wilson 2006-06-29 10:08:06 EDT
Description of problem:

Upgrade path to cscope in current devel tree broken.

cscope:
  5: 0:15.5-13.7 (FC5-updates)
  6: 0:15.5-13.5 (FC6)

Though I see a newer release (13.8) for the devel tree in cvs. Might I also
suggest making use of brew's newly added support for the %{?dist} tag, which is
widely used in Extras?

Example:

RCS file: /cvs/dist/rpms/cscope/devel/cscope.spec,v
retrieving revision 1.26
diff -r1.26 cscope.spec
4c4
< Release: 13.8
---
> Release: 13.8%{?dist}

That would make the next release in the devel tree 15.5-13.8.fc6, and the same
spec could be used for FC5 and older, still preserving the upgrade path.
Comment 1 Neil Horman 2006-06-29 13:16:40 EDT
Thanks, I do need to clean up the cscope versioning.  For now, I've built a
tagged version of cscope-15.5-13.8 to dist-fc6-devel, so it should start getting
pulled into buildroots shortly.

Note You need to log in before you can comment on or make changes to this bug.