Bug 197233 - gconftool-2 hangs during 'yum update' under TWM
gconftool-2 hangs during 'yum update' under TWM
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: GConf2 (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-29 10:49 EDT by Charlie Bennett
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 14:33:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Charlie Bennett 2006-06-29 10:49:21 EDT
Description of problem:

I'm running a freshly installed FC5 system.  After several failed attempts
to get the screen-resolution app to behave as expected I found myself with
a Gnome environment that would not start after login.  So I logged with
a Failsafe Terminal login and started TWM.  Thinking that perhaps I should
pull the post-release updates to see if I could fix my resolution problems
I ran yum update through my squid proxy (using export http_proxy=http://...:3128).

Yum update chugged along happily until hitting the %post script for metacity
and hung with yum eating 100% of one of the CPUs.  Bummer.  I ran an rpm -q
--scripts on metacity and noticed the call to gconftool-2.  Sure enough,
gconftool-2 was locked hard.  Killing gconftool-2 caused yum to continue with
the next RPM.

I had similar lockups during the same session installing gnome-vfs2 and gnome-panel.

Two variables at play here:
 1. I have a DISPLAY but GNOME is not running
 2. I'm yumming through a proxy

None of the orb-o-matic stuff that gnome processes normally use to talk to
each other were running on the box at the time.

Same TWM login session.  Same machine is dual boot with a newly installed FC4
on a different set of partitions.  Under FC5 I mounted my
FC4 partitions, bind-mounted /proc and /sys and chrooted to my FC4 environment.
I was able to pull all of the past year's FC4 updates into my chroot without
encountering the same difficulties updating the packages that caused lockups
under FC5.


Version-Release number of selected component (if applicable):

GConf2-2.13.5-5 (maybe) during a global yum update that updated me
to GConf2-2.14.0-1.

How reproducible:

I happened this once...  it's not the kind of thing I plan on doing often

Steps to Reproduce:
1. install fresh FC5/i386
2. log in as root under X with Failsafe Terminal and start TWM
3. set http_proxy to point at your local yumming squid
4. run yum update
  
Actual results:

RPMS that perform schema updates via gconftool-2 hang when attempting to do so


Expected results:

schema updates should complete without error


Additional info:
Comment 1 Ray Strode [halfline] 2008-03-18 14:33:30 EDT
Hi,

We no longer support Fedora Core 5 and I am currently trying to get my open bug
count down to a more manageable state.  I'm going to close this bug as WONTFIX.
 If this issue is still a concern for you, would you mind trying to reproduce on
a supported version of Fedora and reopening?

(this is a mass message)

Note You need to log in before you can comment on or make changes to this bug.