Bug 1972413 - SELinux is preventing mdadm from 'search' accesses on the directory dma_heap.
Summary: SELinux is preventing mdadm from 'search' accesses on the directory dma_heap.
Keywords:
Status: CLOSED DUPLICATE of bug 1970744
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 34
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:20713be0afdf654345fc3051313...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-06-15 20:16 UTC by Carlos Mogas da Silva
Modified: 2021-06-15 20:53 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-15 20:53:35 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Carlos Mogas da Silva 2021-06-15 20:16:45 UTC
Description of problem:
Happens during boot
SELinux is preventing mdadm from 'search' accesses on the directory dma_heap.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that mdadm should be allowed search access on the dma_heap directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'mdadm' --raw | audit2allow -M my-mdadm
# semodule -X 300 -i my-mdadm.pp

Additional Information:
Source Context                system_u:system_r:mdadm_t:s0
Target Context                system_u:object_r:dma_device_dir_t:s0
Target Objects                dma_heap [ dir ]
Source                        mdadm
Source Path                   mdadm
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
SELinux Policy RPM            selinux-policy-targeted-34.11-1.fc34.noarch
Local Policy RPM              selinux-policy-targeted-34.11-1.fc34.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 5.12.9-300.fc34.x86_64 #1 SMP Thu
                              Jun 3 13:51:40 UTC 2021 x86_64 x86_64
Alert Count                   1
First Seen                    2021-06-15 21:11:20 WEST
Last Seen                     2021-06-15 21:11:20 WEST
Local ID                      9d723056-fa94-4e60-a106-3210ed15ed86

Raw Audit Messages
type=AVC msg=audit(1623787880.860:147): avc:  denied  { search } for  pid=1011 comm="mdadm" name="dma_heap" dev="devtmpfs" ino=149 scontext=system_u:system_r:mdadm_t:s0 tcontext=system_u:object_r:dma_device_dir_t:s0 tclass=dir permissive=0


Hash: mdadm,mdadm_t,dma_device_dir_t,dir,search

Version-Release number of selected component:
selinux-policy-targeted-34.11-1.fc34.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.15.2
hashmarkername: setroubleshoot
kernel:         5.12.9-300.fc34.x86_64
type:           libreport

Comment 1 Zdenek Pytela 2021-06-15 20:53:35 UTC

*** This bug has been marked as a duplicate of bug 1970744 ***


Note You need to log in before you can comment on or make changes to this bug.