Bug 197251 - Istanbul's context menu is hosed
Istanbul's context menu is hosed
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: istanbul (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jef Spaleta
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE6Target
  Show dependency treegraph
 
Reported: 2006-06-29 13:33 EDT by Zack Cerza
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-31 20:00:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screencast of busted menu (27.29 KB, image/gif)
2006-06-29 13:33 EDT, Zack Cerza
no flags Details
istanbul on fc5 right-click menu working properly (295.02 KB, image/png)
2006-08-21 18:47 EDT, Jef Spaleta
no flags Details
Call self.popupmenu.reposition() to fix context menu (378 bytes, patch)
2006-08-22 14:23 EDT, Zack Cerza
no flags Details | Diff
srpm with patched applied, please build and test. (238.68 KB, application/octet-stream)
2006-08-30 18:49 EDT, Jef Spaleta
no flags Details

  None (edit)
Description Zack Cerza 2006-06-29 13:33:13 EDT
Description of problem:
Istanbul's context menu is broken.

Version-Release number of selected component (if applicable):
istanbul-0.1.1-9.fc5.i386

How reproducible:
Always

Steps to Reproduce:
1. Right-click on the Istanbul icon in the notification area

Actual results:
Something strange pops up... will attach Byzanz recording of it

Expected results:
The menu pops up
Comment 1 Zack Cerza 2006-06-29 13:33:13 EDT
Created attachment 131759 [details]
screencast of busted menu
Comment 2 Ian Chapman 2006-08-21 18:29:17 EDT
Just confirming this also occurs with KDE. Any news on a fix for this, seeing as
0.2.1 has been out for a while. It's basically useless as is.
Comment 3 Jef Spaleta 2006-08-21 18:47:31 EDT
Created attachment 134605 [details]
istanbul on fc5 right-click menu working properly
Comment 4 Jef Spaleta 2006-08-21 19:04:44 EDT
A couple of things... 

As you can see in the screenshot istanbul-0.1.1-9.fc5 on my fc5 system has a
working preference menu.  Unless you can help me out by figuring out exactly
what settings on your system cause this problem I can't do much about it. It
works for me and I don't know how to reproduce it.. is it a language setting
problem... is it some package change on your system... i have no idea. What I do
know is that I can't reproduce this on my systems.  

As for 0.2.1.... 0.2.1 is NOT going to show up in fc5 due to missing
capabilities in gstreamer-plugins-good in FC5. I am working on a package right
now for fc6, but let me stress that istanbul 0.2.1 has completely new ui issues
that need to be worked on upstream with the developers. If you are interested in
working with the upstream developers, please go ahead and build 0.2.1 on your
system using the gstreamer components from fedora core development tree (as I am
doing currently) and start filing bugreports and patches with the upstream
developers. Much of istanbul's problems are not fedora package specific and need
to be addressed upstream. 

-jef
Comment 5 Zack Cerza 2006-08-22 11:53:53 EDT
Jef,

Have you tried putting your notification area on the bottom panel?
Comment 6 Jef Spaleta 2006-08-22 13:55:28 EDT
The good news... I can confirm that using the notification area on the bottom
panel causes the problem... so its definitely a bug.

The bad news... this isn't something I can fix at the packaging level, without
someone providing a patch.  

The darkly ironic news.... istanbul 0.2.1 does not have this problem as far as I
can tell, but istanbul 0.2.1 can not be pushed into fc5 because the gstreamer in
fc5 does not have the ncessary ximagesrc capability. The developement tree will
most likely get an 0.2.1 build soon.

Considering the choices, I'm leaving this bug report open in case someone has
time and the ability to implement a patch.. a patch that upstream may not be
that interesting in helping to create considering that the newest version of
istanbul has had a significant amount of ui rework and doesn't exhibit this
problem.  

-jef
Comment 7 Zack Cerza 2006-08-22 14:23:38 EDT
Created attachment 134655 [details]
Call self.popupmenu.reposition() to fix context menu

Turns out the fix is easy. Just call self.popupmenu.reposition() after
self.popupmenu.show_all(). Apply this patch with -p0.
Comment 8 Zack Cerza 2006-08-22 14:25:38 EDT
This fix works whether the notification area is on the top or bottom of the screen.
Comment 9 Jef Spaleta 2006-08-22 14:41:28 EDT
Excellent!

I'll I'll test that fix on my fc5 box here, and then I'll see if I can get that
committed into the Extras build system for a push.  You'll have to give me a
couple of days, I've moved cross-country in the last 2 months and I'm just now
getting a linux box up and running in my office at work. If you don't see an
istanbul push to fe5 by the end of the week, beat me up.

-jef
Comment 10 Zack Cerza 2006-08-22 15:05:41 EDT
I can totally sympathize; I'm moving too and it's been "very interesting". I'll
start bugging you Friday or so.
Comment 11 Jef Spaleta 2006-08-25 13:26:04 EDT
I'm trying to get something out today... but since the last time I wrote we've 
had a major network issue at work so I'm not even sure if I'm going to be able 
to get a package out until next week and even then I might have to sucker 
another maintainer to do the commit for me.

-jef
Comment 12 Jef Spaleta 2006-08-30 18:49:43 EDT
Created attachment 135248 [details]
srpm with patched applied, please build and test.

Here is the srpm I plan to submit or have someone else submit to the FE
buildsystem as soon as its available again. My understanding is that the
buildsystem is down currently. Hopefully tomorrow I can get this submitted and
building.

-jef
Comment 13 Jef Spaleta 2006-08-31 20:00:37 EDT
Package was pushed and built in fe5, its awaiting signature. Closing as next
release, please re-open if problems linger after testing the update.

-jef

Note You need to log in before you can comment on or make changes to this bug.