Bug 197268 - liblvm2cmd not working properly - causing kill of dmeventd during cmirror fault handling
liblvm2cmd not working properly - causing kill of dmeventd during cmirror fau...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2 (Show other bugs)
4.0
All Linux
high Severity high
: ---
: ---
Assigned To: Jonathan Earl Brassow
:
Depends On:
Blocks: 181411
  Show dependency treegraph
 
Reported: 2006-06-29 14:56 EDT by Jonathan Earl Brassow
Modified: 2007-11-30 17:07 EST (History)
8 users (show)

See Also:
Fixed In Version: RHBA-2006-0434
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 17:26:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Earl Brassow 2006-06-29 14:56:42 EDT
Single machine mirroring is unaffected by this bug.

When a device fails in a mirror, dmeventd is called to handle the event.  This
in turn calls the mirror specific DSO.  The DSO determines that a device has
failed and calls 'vgreduce --removemissing <vg>'.

When that command (run through the liblvm2cmd interface) is called, it loads the
cluster locking library.  Upon the very first call into the locking library, the
program dies.  I haven't determined the cause.  All pointers to functions seem
to be fine, but when _lock_fn is called, dmeventd mysteriously dies.

A _very_ simple workaround is to use 'system()' rather than calling 'lvm2_run'.
 I've tested this, and it works.  I realize that there are memory issues
involved in the forking/etc of this new process, but we have memory issues with
the logging anyway and it's better than having the program die.

Certainly, we will have to fix liblvm2cmd, but I don't understand the problem
there and that could take some time.
Comment 1 Jonathan Earl Brassow 2006-06-29 14:59:12 EDT
This should be considered a blocker.  However, if we get the simple fix in, we
could probably reduce the severity.
Comment 4 Alasdair Kergon 2006-07-04 16:23:59 EDT
We have identified some things that need fixing with the library but have opted
to use the workaround for this release.
Comment 9 Red Hat Bugzilla 2006-08-10 17:26:05 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0434.html

Note You need to log in before you can comment on or make changes to this bug.