Bug 1972694 - Topology edit icon does not link correctly when branch name contains slash
Summary: Topology edit icon does not link correctly when branch name contains slash
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.z
Assignee: Mohammed Saud
QA Contact: spathak@redhat.com
Harsh Mishra
URL:
Whiteboard:
Depends On: 1969536
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-06-16 12:30 UTC by OpenShift BugZilla Robot
Modified: 2021-09-06 06:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the topology URLs created for deployments using a Bitbucket repository in the {product-title} web console did not work if they included a branch name that contained a slash character. This was due to an issue with the Bitbucket API link:https://jira.atlassian.com/browse/BCLOUD-9969[BCLOUD-9969]. The current release mitigates this issue: if a branch name contains a slash, the topology URLs point to the default branch page for the repository.
Clone Of:
Environment:
Last Closed: 2021-07-14 07:16:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 9271 0 None open [release-4.6] [release-4.7] Bug 1972694: Omit bitbucket branch in URL if it contains slash 2021-06-21 01:01:08 UTC
Red Hat Product Errata RHBA-2021:2641 0 None None None 2021-07-14 07:16:47 UTC

Description OpenShift BugZilla Robot 2021-06-16 12:30:07 UTC
+++ This bug was initially created as a clone of Bug #1969536 +++

+++ This bug was initially created as a clone of Bug #1969535 +++

Description of problem:
Topology edit icon for deployments created using git flow do not link to the repo correctly when the branch name contains a forward slash(/).

Related: https://issues.redhat.com/browse/ODC-5901

Version-Release number of selected component (if applicable):
4.8


How reproducible:
Always, only for bitbucket repos.

Steps to Reproduce:
Set annotations on a deployment:

app.openshift.io/vcs-uri: https://company.com/projects/XYZ/repos/foo-project/browse
app.openshift.io/vcs-ref: feature/x-111

Actual results:
Edit icon url is broken.


Expected results:
Edit icon url should have the correct bitbucket link


Additional info:
This may be a problem with bitbucket's API. See https://jira.atlassian.com/browse/BCLOUD-9969

Comment 4 spathak@redhat.com 2021-06-28 16:50:25 UTC
Verified on build version: 4.6.0-0.nightly-2021-06-25-031210
Browser: Google Chrome 89

Comment 9 errata-xmlrpc 2021-07-14 07:16:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.38 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:2641


Note You need to log in before you can comment on or make changes to this bug.