RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1973030 - [perl-net-ping] wrong return value on failing DNS name lookup
Summary: [perl-net-ping] wrong return value on failing DNS name lookup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: perl
Version: 8.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: beta
: ---
Assignee: perl-maint-list
QA Contact: Martin Kyral
URL:
Whiteboard:
Depends On:
Blocks: 1973176 1973177
TreeView+ depends on / blocked
 
Reported: 2021-06-17 07:05 UTC by Stefan Meyer
Modified: 2021-11-10 09:27 UTC (History)
2 users (show)

Fixed In Version: perl-5.26.3-420.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1973176 1973177 (view as bug list)
Environment:
Last Closed: 2021-11-09 19:51:30 UTC
Type: Bug
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)
Replace croak by carp (3.02 KB, patch)
2021-06-17 10:08 UTC, Jitka Plesnikova
no flags Details | Diff
Fix _resolv return value (1.69 KB, patch)
2021-06-17 10:09 UTC, Jitka Plesnikova
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2021:4459 0 None None None 2021-11-09 19:51:34 UTC

Description Stefan Meyer 2021-06-17 07:05:55 UTC
Description of problem:
The perl-net-ping module delivers the wrong return value on failing DNS name lookup


Version-Release number of selected component (if applicable):
- Tested with perl-Net-Ping-2.55-419.el8.noarch in RHEL 8.4
- Found by a customer on RHEL 8.2

How reproducible:
- With non-existing dns hosts

Steps to Reproduce:
1. install perl-Net-Ping-2.55-419.el8.noarch
2. create example perl script:
   
   use Net::Ping;
   $ping = Net::Ping->new('tcp');
   $result = $ping->ping('blah.example.com'); # host does not exist in DNS.
   if (defined $result && $result)
      { print "OK\n"; }
   else
      { print "ERROR\n"; }

3. run script

Actual results:
Error message is displayed:
getaddrinfo(blah.lnx.aaxc.org,,AF_INET) failed - Name or service not known at test.pl line 3.

Expected results:
The output should be "ERROR"

Additional info:
Looks like this has been fixed upstream: https://metacpan.org/dist/Net-Ping/changes (line 60)

------------------------------------------------
2.68  Wed Jun 27 11:55:06 CEST 2018 (rurban)
       Bugfixes
       - Fixed _resolv return value on failing DNS name lookup. (GH #12 nlv02636)
------------------------------------------------

Comment 2 Jitka Plesnikova 2021-06-17 07:39:10 UTC
Thank you for report. I can confirm the issue.

perl-Net-Ping is subpackage of perl.

Comment 3 Jitka Plesnikova 2021-06-17 08:50:53 UTC
These two changes has to be backported to solve the issue. 

2.68  Wed Jun 27 11:55:06 CEST 2018 (rurban)
       Bugfixes
       - Fixed _resolv return value on failing DNS name lookup. (GH #12 nlv02636)

2.67  Mon Jun 25 18:10:42 CEST 2018 (rurban)
       Bugfixes
       - Change croak on failing name lookup to return undef,
         matching the documentation.
         Fixes the regression from 2.43, RT #124830


After the fix, final result of the reproducer will be:
# perl bz1973030.pl 
getaddrinfo(blah.example.com,,AF_INET) failed - Name or service not known at /usr/share/perl5/Net/Ping.pm line 1861.
ERROR

Comment 4 Jitka Plesnikova 2021-06-17 10:08:10 UTC
Created attachment 1791764 [details]
Replace croak by carp

Comment 5 Jitka Plesnikova 2021-06-17 10:09:12 UTC
Created attachment 1791765 [details]
Fix _resolv return value

Comment 13 errata-xmlrpc 2021-11-09 19:51:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (perl bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4459


Note You need to log in before you can comment on or make changes to this bug.