Bug 197315 - rescue mode: no shell on VT1 for empty rescue
rescue mode: no shell on VT1 for empty rescue
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-30 00:42 EDT by John Reiser
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-07 14:31:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2006-06-30 00:42:01 EDT
Description of problem:
If you select no partition to rescue, then rescue mode says it is giving you a
shell, but instead it does nothing on VT1.  You have to know to type <alt>F2 and
use the shell on VT2.

Version-Release number of selected component (if applicable):
anaconda-11.1.0.49-1
FC-develoopment-i386-rescuecd.iso 2006-06-29
md5sum a2340818a037e870bffe7332ea4f64f9

How reproducible:
always

Steps to Reproduce:
1. boot: linux rescue
2. Select language, keyboard, no network, no partition to rescue.
3.
  
Actual results:
"When finished please exit from the shell and your system will reboot." but no
shell prompt on VT1, and typing on VT1 does not echo, and VT1 does not respond.
 On VT2 there is a shell, where "ps axl" shows anaconda in state "wait  S+". 
"top" reveals that no process is using CPU (anaconda, loader, two sh, two init,
...).

Expected results:
Shell prompt on VT1.

Additional info:
Comment 1 David Cantrell 2006-07-07 14:31:15 EDT
Chris Lumens fixed it in rawhide.
Comment 2 John Reiser 2006-07-08 10:49:41 EDT
Confirmed: works for me in anaconda-11.1.0.54-1.

Note You need to log in before you can comment on or make changes to this bug.