Bug 197328 - OpenGL apps crash with DRI and SELinux enabled
OpenGL apps crash with DRI and SELinux enabled
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-30 04:31 EDT by Hans de Goede
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-26 20:20:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2006-06-30 04:31:59 EDT
Hi,

On a fully up2date rawhide system I need todo a "setenforce 0" before I can
successfully run any opengl apps. If I don't do the "setenforce 0" They crash
somewhere in 915_dri.so in a function called something with mmx or sse in the name.

Unfortunatly I'm not behind the involved machine atm, nor do I have access, thus
I also cannot check audit.log. Still I thought it would be good to report this
before I forgot. I'm using the targeted SELinux policy.

I think (have a hunch) it has something todo with the i915 driver generating mmx
or sse assembler code on the fly and the mprotect call failing because SELinux
denies it. But thats just a hunch.
Comment 1 Adam Jackson 2006-07-26 20:20:22 EDT
Should be sorted in mesa-6.5-19 and later.  Please reopen if this issue reoccurs.
Comment 2 Hans de Goede 2006-07-27 02:42:03 EDT
I don't have access to the involved machine untill august 21, did you / could
you verify the fix yourself, augustus 21 might be a bit late with regards to the
FC-6 cycle.

Note You need to log in before you can comment on or make changes to this bug.