Bug 197333 - LDAP auth crashing on x86_64
LDAP auth crashing on x86_64
Status: CLOSED DUPLICATE of bug 188073
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Joe Orton
Depends On:
  Show dependency treegraph
Reported: 2006-06-30 06:23 EDT by Lars Heete
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-07-03 05:06:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Bugfix for apr (506 bytes, patch)
2006-07-03 04:43 EDT, Bernie Innocenti
no flags Details | Diff

  None (edit)
Description Lars Heete 2006-06-30 06:23:59 EDT
Description of problem:

Version-Release number of selected component (if applicable):
httpd-2.2.0-5.1.2 openldap-2.3.19-4 apr-1.2.2-7.3

How reproducible:
configure apache to use ldap on x86_64, in instantly segfaults when used.

Additional info:

openldap in FC5 hides the declaration of many functions that are deprecated 
(eg. ldap_init in <ldap.h>). Without decl the return type defaults to int, and 
with functions that return pointers you get illegal addresses on 64bit.
To get the missing declarations of openldap the -DLDAP_DEPRECATED definition 
is needed at compile time.

Lars Heete
Comment 1 Bernie Innocenti 2006-07-03 03:51:15 EDT
Just noticed the same problem here (x86_64).

It still happens with httpd-2.2.2-1.0.x86_64.
Comment 2 Lars Heete 2006-07-03 03:53:56 EDT
apr-util actually has the same Problem.
Comment 3 Bernie Innocenti 2006-07-03 04:40:37 EDT
Attaching a patch that fixed the problem for me.

Please note that it must be applied to apr, altough
the package containing wrong code is apr-util.

The new apr-devel must be installed while rebuilding
Comment 4 Bernie Innocenti 2006-07-03 04:43:18 EDT
Created attachment 131875 [details]
Bugfix for apr

Please add to apr.spec and rebuild both apr and apr-util
with new apr-devel already installed.
Comment 5 Joe Orton 2006-07-03 05:06:40 EDT
Thanks, there is an apr-util update in the update queue already.  It's not
necessary to make changes to apr to fix this issue.

*** This bug has been marked as a duplicate of 188073 ***

Note You need to log in before you can comment on or make changes to this bug.