Bug 1973675 - HF request to backport upstream PRs 2524,2544,2562,2585 into sos 4.0
Summary: HF request to backport upstream PRs 2524,2544,2562,2585 into sos 4.0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: sos
Version: 8.4
Hardware: x86_64
OS: Linux
urgent
high
Target Milestone: beta
: ---
Assignee: Pavel Moravec
QA Contact: Miroslav Hradílek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-06-18 13:03 UTC by Pavel Moravec
Modified: 2021-11-10 07:45 UTC (History)
6 users (show)

Fixed In Version: sos-4.1-3.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-09 19:36:31 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github sosreport sos pull 2524 0 None closed [cleaner] Remove binary files by default 2021-06-18 13:03:28 UTC
Github sosreport sos pull 2544 0 None closed [collect|ocp] Add an OCP4 collect profile, add registry auth options, improve containerized execution 2021-06-18 13:03:28 UTC
Github sosreport sos pull 2562 0 None closed [cleaner] Don't strip empty lines from substituted files 2021-06-18 13:03:28 UTC
Github sosreport sos pull 2585 0 None open [collect,clean,ocp] Enhance OCP cluster collection and archive cleaning 2021-06-18 13:03:28 UTC
Red Hat Product Errata RHEA-2021:4388 0 None None None 2021-11-09 19:36:56 UTC

Description Pavel Moravec 2021-06-18 13:03:28 UTC
Description of problem:
There is a HF request to backport:

https://github.com/sosreport/sos/pull/2524
https://github.com/sosreport/sos/pull/2544
https://github.com/sosreport/sos/pull/2562
https://github.com/sosreport/sos/pull/2585

into sos-4.0 in RHEL8.4.

The HF won't have an errata and is planned to be included in 8.5.


Version-Release number of selected component (if applicable):
sos-4.0

How reproducible:
100%


Steps to Reproduce:
See particular info in the four PRs; various OCP cluster collection and obfuscation requirements there.


Actual results:
Neither PR included in sos for 8.4.


Expected results:
A sos version with the 4 PRs included.


Additional info:
All verification specific to this ticket has been agreed to be provided by the customer requesting this functionality.

Comment 6 errata-xmlrpc 2021-11-09 19:36:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (sos bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2021:4388


Note You need to log in before you can comment on or make changes to this bug.