Bug 197394 - Cron needs to become more intelligent - not run certain jobs on batteries
Cron needs to become more intelligent - not run certain jobs on batteries
Status: CLOSED DUPLICATE of bug 190268
Product: Fedora
Classification: Fedora
Component: vixie-cron (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-30 15:59 EDT by David Anderson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-11 11:29:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Anderson 2006-06-30 15:59:00 EDT
Cron is badly behind the capabilities of the Win XP task scheduler in some 
areas.

If the prelink monster runs when I am on batteries, then it reduces my battery 
time by about 25%. Seriously.

Hence I do not want prelink to run if on batteries. I could file this as a bug 
against prelink, but I think that cron should have this ability.

It needs to associate flags with jobs, which then decide whether execution 
should go ahead. One flag would be "do not run if on batteries". When the time 
comes to run the job, cron would then detect that we're on batteries (via 
HAL?) and refuse to run the job.

This message looks relevant too, as it suggests a wholesale replacement of 
vixie-cron with a particular alternative:
https://www.redhat.com/archives/fedora-devel-list/2006-June/msg00583.html
Comment 1 Marcela Mašláňová 2007-07-11 11:29:13 EDT

*** This bug has been marked as a duplicate of 190268 ***

Note You need to log in before you can comment on or make changes to this bug.