Bug 1973997 - kajongg and kajonggserver symbolic links point to non-existent files
Summary: kajongg and kajonggserver symbolic links point to non-existent files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kajongg
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2001222 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-06-19 18:14 UTC by sokerijuurikas
Modified: 2021-09-07 16:26 UTC (History)
5 users (show)

Fixed In Version: kajongg-20.08.0-3.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-07 16:26:27 UTC
Type: Bug


Attachments (Terms of Use)

Description sokerijuurikas 2021-06-19 18:14:58 UTC
Description of problem:
The package adds symbolic links in /usr/bin/ but these point to non-existent files.

> ls -l /usr/bin/kajongg*
lrwxrwxrwx. 1 root root 62 Jan 27 03:16 /usr/bin/kajongg -> /builddir/build/BUILD/kajongg-20.08.0/share/kajongg/kajongg.py
lrwxrwxrwx. 1 root root 68 Jan 27 03:16 /usr/bin/kajonggserver -> /builddir/build/BUILD/kajongg-20.08.0/share/kajongg/kajonggserver.py

This causes the provided .desktop file not to work and also prevents one from starting the game by just running "kajongg". The game can still be started by directly running "python /usr/share/kajongg/kajongg.py". I did not test the server.

Version-Release number of selected component (if applicable):
kajongg-20.08.0-2.fc34.noarch

How reproducible:
Always

Steps to Reproduce:
1. dnf install kajongg
2. ls -l /usr/bin/kajongg*

Comment 1 Than Ngo 2021-09-06 09:15:27 UTC
It's fixed in kajongg-20.08.0-3.fc34

Comment 2 Than Ngo 2021-09-06 09:19:12 UTC
*** Bug 2001222 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2021-09-06 09:22:52 UTC
FEDORA-2021-d47ef203b8 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-d47ef203b8

Comment 4 Fedora Update System 2021-09-07 00:02:40 UTC
FEDORA-2021-d47ef203b8 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-d47ef203b8`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-d47ef203b8

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2021-09-07 16:26:27 UTC
FEDORA-2021-d47ef203b8 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.