Bug 197402 - RFE: option to Enable IPv4/IPv6 in Configure TCP/IP dialog
RFE: option to Enable IPv4/IPv6 in Configure TCP/IP dialog
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Mike McLean
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-06-30 17:53 EDT by John Reiser
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-08 10:24:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2006-06-30 17:53:25 EDT
Description of problem:
For network installs, the dialog "Configure TCP/IP" should have separate check
boxes to enable IPv4 and IPv6, with the default being ON.  So there would be
three check boxes:
  [*] Use dynamic IP configuration (BOOTP/DHCP)
  [*] Enable IPv4
  [*] Enable IPv6

Specifing "noipv6" as a "boot: linux" paraeter partially covers turning off
Enable IPv6, but that requires planning too far in advance (using it becomes a
two-pass process) and does not allow for separate independent Enable IPv4.

Version-Release number of selected component (if applicable):
anaconda-11.1.0.49-1

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthias Saou 2006-07-03 07:37:00 EDT
I definitely second this request since when using DHCP for a network
installation on a network where only IPv4 is enabled, the IPv6 DHCP request
takes nearly 1 minute to timeout after the IPv4 one worked instantly.
It'll be quite annoying for many users (IPv6 still isn't that common), so having
an easy way to disable it would be verey welcome.
Comment 2 Jeremy Katz 2006-07-03 23:45:23 EDT
David was going to add this I believe
Comment 3 John Reiser 2006-07-08 10:24:13 EDT
Works for me in anaconda-11.1.0.54-1.  Thank you.

Note You need to log in before you can comment on or make changes to this bug.