Bug 1974267 - oc logs doesn't work with piepeline builds
Summary: oc logs doesn't work with piepeline builds
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.8
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.8.z
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On: 1973643
Blocks: 1974264
TreeView+ depends on / blocked
 
Reported: 2021-06-21 08:52 UTC by OpenShift BugZilla Robot
Modified: 2021-08-16 18:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Missing client setup in logs command. Consequence: oc logs doesn't work with pipeline builds. Fix: Properly setup client in logs command. Result: oc logs works with pipeline builds.
Clone Of:
Environment:
Last Closed: 2021-08-16 18:32:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift oc pull 867 0 None open [release-4.8] Bug 1974267: make oc logs work with BuildConfig's JenkinsPipeline strategy 2021-06-21 10:20:24 UTC
Red Hat Product Errata RHBA-2021:3121 0 None None None 2021-08-16 18:32:28 UTC

Comment 3 zhou ying 2021-08-09 08:09:46 UTC
can't reproduce with latest oc now:

oc new-app -f https://raw.githubusercontent.com/openshift/origin/master/examples/jenkins/pipeline/samplepipeline.yaml

[root@localhost home]# oc  logs -f bc/sample-pipeline
error: the pipeline strategy build  does not yet contain the log URL; wait a few moments, then try again

See 'oc version --help' for usage.
[root@localhost home]# oc version --client
Client Version: 4.8.0-202108061819.p0.git.c6ad8ac.assembly.stream-c6ad8ac

Comment 6 errata-xmlrpc 2021-08-16 18:32:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.5 security update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3121


Note You need to log in before you can comment on or make changes to this bug.