This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 197432 - yum --exclude=pkg update fails
yum --exclude=pkg update fails
Status: CLOSED DUPLICATE of bug 197421
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-01 05:01 EDT by Thomas Steudten
Modified: 2014-01-21 17:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-03 23:21:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas Steudten 2006-07-01 05:01:23 EDT
Description of problem: yum fails to update due to ignoring options --exclude


Version-Release number of selected component (if applicable): yum-2.6.1-0.fc5



How reproducible: yum update 


Steps to Reproduce:
1. yum update [07/01/2006] gives
[..]
---> Package nfs-utils-lib.i386 0:1.0.8-4.FC5 set to be updated
---> Package xorg-x11-server-Xnest.i386 0:1.0.1-9.fc5.5 set to be updated
--> Running transaction check
--> Processing Dependency: librpcsecgss.so.1 for package: nfs-utils
--> Processing Dependency: libgssapi.so.1 for package: nfs-utils
--> Finished Dependency Resolution
Error: Missing Dependency: librpcsecgss.so.1 is needed by package nfs-utils
Error: Missing Dependency: libgssapi.so.1 is needed by package nfs-utils


2. yum --exclude=nfs-utils* update gives
[..]
---> Package gnupg.i386 0:1.4.4-2 set to be updated
---> Package xorg-x11-server-Xnest.i386 0:1.0.1-9.fc5.5 set to be updated
--> Running transaction check
--> Processing Dependency: libgssapi.so.1 for package: nfs-utils
--> Finished Dependency Resolution
Error: Missing Dependency: libgssapi.so.1 is needed by package nfs-utils

3.
  
Actual results: yum fails to do unresolving dependency


Expected results: yum should update all packages without the ones given with
--exclude.


Additional info:
Comment 1 Jeremy Katz 2006-07-03 23:21:33 EDT
You also need to --exclude=libgssapi*

*** This bug has been marked as a duplicate of 197421 ***
Comment 2 Thomas Steudten 2006-07-04 11:22:40 EDT
See this two lines:
Error: Missing Dependency: librpcsecgss.so.1 is needed by package nfs-utils
Error: Missing Dependency: libgssapi.so.1 is needed by package nfs-utils

.. needed for package nfs-utils.
So, this means, if someone exclude nfs-utils, the dependency should be solved -
this isnt' the case here.
You write a work-around, not the bug fix.

Note You need to log in before you can comment on or make changes to this bug.