Bug 1974327 - proxyfuzz fails to build: Macro %python_sitelib failed to expand
Summary: proxyfuzz fails to build: Macro %python_sitelib failed to expand
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: proxyfuzz
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Sklenar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F34FTBFS F35FTBFS F33FTBFS
TreeView+ depends on / blocked
 
Reported: 2021-06-21 11:43 UTC by Miro Hrončok
Modified: 2021-07-13 15:24 UTC (History)
1 user (show)

Fixed In Version: proxyfuzz-20190404-18.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-13 15:24:21 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2021-06-21 11:43:18 UTC
Description of problem:
The package proxyfuzz fails to build the SRPM in Koji: Macro %python_sitelib failed to expand.

Version-Release number of selected component (if applicable):
proxyfuzz-20190404-18.fc35

How reproducible:
build the package in Koji


Steps to Reproduce:
1. fedpkg clone proxyfuzz
2. cd proxyfuzz
3. fedpkg build

Actual results:
BuildError: error building srpm, mock exited with status 1; see build.log or root.log for more information
...
error: attempt to use unversioned python, define %__python to /usr/bin/python2 or /usr/bin/python3 explicitly
  4<          (%error)
  3<        (%__python)
  2<      (%)
error: /builddir/build/SPECS/proxyfuzz.spec: line 1: Macro %python_sitelib failed to expand
  1<    (%global)
  0<  (%)

Expected results:
Package builds.

Additional info:
This is caused by https://fedoraproject.org/wiki/Changes/PythonMacroError and can be solved by removing an unused first line from the specfile.

Comment 1 Fedora Release Engineering 2021-07-11 04:23:05 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 35.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2021-08-16).

A week before the mass branching of Fedora 36 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 34 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-36/f-36-key-tasks.html

Comment 2 Miro Hrončok 2021-07-13 15:24:21 UTC
I've pushed the fix as provenpackager.


Note You need to log in before you can comment on or make changes to this bug.