Bug 1974466 - iconv fails
Summary: iconv fails
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Carlos O'Donell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1974253
TreeView+ depends on / blocked
 
Reported: 2021-06-21 18:36 UTC by Gwyn Ciesla
Modified: 2021-06-22 14:58 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-22 14:58:56 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Gwyn Ciesla 2021-06-21 18:36:53 UTC
Description of problem:
iconv error breaks package buil build

Version-Release number of selected component (if applicable):
2.33.9000-23.fc35 

How reproducible:
Build Io-language
<snip>
patching file libs/iovm/source/IoSystem.c
+ sed -i 's|/lib/io/addons|/lib64/io/addons|g' libs/iovm/io/AddonLoader.io
+ '[' -f /usr/include/io/IoVM.h ']'
+ rm -fr addons/AVCodec
+ rm -rf addons/ODE
+ sed -i /ODE/d addons/CMakeLists.txt
+ iconv -f MACINTOSH -t UTF8 libs/basekit/license/bsd_license.txt
iconv: failed to start conversion processing
RPM build errors:
error: Bad exit status from /var/tmp/rpm-tmp.pNDoFo (%prep)
<snip>

Works on f34.

Comment 1 Siddhesh Poyarekar 2021-06-22 02:25:59 UTC
Sorry I didn't announce this change, mainly because I didn't anticipate buildroots not installing weak dependencies: the gconv package was split in glibc-2.33.9000-13.fc35 to put all of the non-UTF* modules into the glibc-gconv-extra package.  This is to reduce space usage in minimal installations and to allow security hardening for unicode-only systems since the converter modules are an easy attack surface.

To bring in the MACINTOSH locale Io-languages needs a BuildRequires on glibc-gconv-extra.  Could you please add that?

Comment 2 Gwyn Ciesla 2021-06-22 14:58:56 UTC
That worked, thank you!


Note You need to log in before you can comment on or make changes to this bug.