Bug 197449 - List corruption in kernel after trying to play midi with aplaymidi
List corruption in kernel after trying to play midi with aplaymidi
Status: CLOSED DUPLICATE of bug 194597
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-01 15:32 EDT by Vedran Miletić
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-02 09:43:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vedran Miletić 2006-07-01 15:32:31 EDT
Description of problem:
Playing midi with aplaymidi triggers a kernel bug.

Version-Release number of selected component (if applicable):
[vedranic@coldharbour ~]$ uname -a
Linux coldharbour 2.6.17-1.2139_FC5 #1 Fri Jun 23 12:40:16 EDT 2006 i686 i686
i386 GNU/Linux

How reproducible:
Every time.

Steps to Reproduce:
1. Go to terminal.
2. aplaymidi -p 0:0 some_file.mid
  
Actual results:
Jul  1 21:24:55 coldharbour kernel: List corruption. next->prev should be
c829b048, but was c41bc148
Jul  1 21:24:55 coldharbour kernel: ------------[ cut here ]------------
Jul  1 21:24:55 coldharbour kernel: kernel BUG at include/linux/list.h:58!
Jul  1 21:24:55 coldharbour kernel: invalid opcode: 0000 [#1]
Jul  1 21:24:55 coldharbour kernel: last sysfs file: /class/net/eth0/carrier
Jul  1 21:24:55 coldharbour kernel: Modules linked in: snd_rtctimer sd_mod sg
usb_storage scsi_mod snd_usb_audio snd_usb_lib snd_rawmidi snd_hwdep autofs4
hidp rfcomm l2cap bluetooth sunrpc ip_conntrack_netbios_ns ipt_REJECT xt_state
ip_conntrack nfnetlink xt_tcpudp iptable_filter ip_tables x_tables dm_multipath
video button battery ac fglrx(U) ipv6 lp parport_pc parport ehci_hcd uhci_hcd
ohci1394 joydev ieee1394 ipw2200 ieee80211 ieee80211_crypt snd_intel8x0m 8139cp
snd_intel8x0 snd_ac97_codec snd_ac97_bus snd_seq_dummy 8139too snd_seq_oss mii
snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm
snd_timer i2c_i801 snd soundcore snd_page_alloc i2c_core dm_snapshot dm_zero
dm_mirror dm_mod ext3 jbd
Jul  1 21:24:55 coldharbour kernel: CPU:    0
Jul  1 21:24:55 coldharbour kernel: EIP:    0060:[<e0931234>]    Tainted: P      VLI
Jul  1 21:24:55 coldharbour kernel: EFLAGS: 00210096   (2.6.17-1.2139_FC5 #1) 
Jul  1 21:24:55 coldharbour kernel: EIP is at
snd_seq_delete_all_ports+0x60/0x176 [snd_seq]
Jul  1 21:24:55 coldharbour kernel: eax: 00000044   ebx: c829b048   ecx:
c06bbfd0   edx: cca7e550
Jul  1 21:24:55 coldharbour kernel: esi: c829b048   edi: c41bc148   ebp:
c41bc0c0   esp: c0cbaec8
Jul  1 21:24:55 coldharbour kernel: ds: 007b   es: 007b   ss: 0068
Jul  1 21:24:55 coldharbour kernel: Process aplaymidi (pid: 4900,
threadinfo=c0cba000 task=cca7e550)
Jul  1 21:24:55 coldharbour kernel: Stack: e0932432 c829b048 c41bc148 c41bc15c
c41bc150 00200286 22222222 22222222 
Jul  1 21:24:55 coldharbour kernel:        c41bc0c0 de89c4fc de89c4fc cb7f3440
e092c1bc c41bc0c0 e092c26e 00000000 
Jul  1 21:24:55 coldharbour kernel:        de89c684 00000008 c41bc0c0 e092c2bc
00000008 c045ce66 00000000 dfd0d524 
Jul  1 21:24:55 coldharbour kernel: Call Trace:
Jul  1 21:24:55 coldharbour kernel:  <e092c1bc> seq_free_client1+0x8/0x7e
[snd_seq]  <e092c26e> seq_free_client+0x3c/0x78 [snd_seq]
Jul  1 21:24:55 coldharbour kernel:  <e092c2bc> snd_seq_release+0x12/0x31
[snd_seq]  <c045ce66> __fput+0xb2/0x158
Jul  1 21:24:55 coldharbour kernel:  <c045a798> filp_close+0x52/0x59  <c041d914>
put_files_struct+0x63/0xa5
Jul  1 21:24:55 coldharbour kernel:  <c041e9db> do_exit+0x1f8/0x768  <c0405a04>
do_syscall_trace+0x126/0x16d
Jul  1 21:24:55 coldharbour kernel:  <c041efb8> sys_exit_group+0x0/0xd 
<c0402cb3> syscall_call+0x7/0xb
Jul  1 21:24:55 coldharbour kernel: Code: 00 00 74 6d 8b 9d 88 00 00 00 8b b5 8c
00 00 00 8b 43 04 39 f0 74 1c 89 74 24 04 89 44 24 08 c7 04 24 32 24 93 e0 e8 8f
b7 ae df <0f> 0b 3a 00 1d 24 93 e0 8b 06 39 d8 74 1c 89 5c 24 04 89 44 24 
Jul  1 21:24:55 coldharbour kernel: EIP: [<e0931234>]
snd_seq_delete_all_ports+0x60/0x176 [snd_seq] SS:ESP 0068:c0cbaec8
Jul  1 21:24:55 coldharbour kernel:  <3>BUG: sleeping function called from
invalid context at include/linux/rwsem.h:43
Jul  1 21:24:55 coldharbour kernel: in_atomic():0, irqs_disabled():1
Jul  1 21:24:55 coldharbour kernel:  <c0426d8d>
blocking_notifier_call_chain+0x18/0x49  <c041e7fc> do_exit+0x19/0x768
Jul  1 21:24:55 coldharbour kernel:  <c05290e7> do_unblank_screen+0x2a/0x127 
<c04042c0> die+0x27b/0x2a0
Jul  1 21:24:55 coldharbour kernel:  <c04048a5> do_invalid_op+0x0/0xab 
<c0404947> do_invalid_op+0xa2/0xab
Jul  1 21:24:55 coldharbour kernel:  <e0931234>
snd_seq_delete_all_ports+0x60/0x176 [snd_seq]  <c0521415>
n_tty_receive_buf+0xc7e/0xcc9
Jul  1 21:24:55 coldharbour kernel:  <c05213be> n_tty_receive_buf+0xc27/0xcc9 
<c042f6aa> debug_mutex_add_waiter+0x1c/0x2c
Jul  1 21:24:55 coldharbour kernel:  <c04037df> error_code+0x4f/0x54  <e0931234>
snd_seq_delete_all_ports+0x60/0x176 [snd_seq]
Jul  1 21:24:55 coldharbour kernel:  <e092c1bc> seq_free_client1+0x8/0x7e
[snd_seq]  <e092c26e> seq_free_client+0x3c/0x78 [snd_seq]
Jul  1 21:24:55 coldharbour kernel:  <e092c2bc> snd_seq_release+0x12/0x31
[snd_seq]  <c045ce66> __fput+0xb2/0x158
Jul  1 21:24:55 coldharbour kernel:  <c045a798> filp_close+0x52/0x59  <c041d914>
put_files_struct+0x63/0xa5
Jul  1 21:24:55 coldharbour kernel:  <c041e9db> do_exit+0x1f8/0x768  <c0405a04>
do_syscall_trace+0x126/0x16d
Jul  1 21:24:55 coldharbour kernel:  <c041efb8> sys_exit_group+0x0/0xd 
<c0402cb3> syscall_call+0x7/0xb
Jul  1 21:24:55 coldharbour kernel: Fixing recursive fault but reboot is needed!

Expected results:
Sound of a song I tried to play.

Additional info:
Do you need any?
Comment 1 Vedran Miletić 2006-07-02 09:43:33 EDT

*** This bug has been marked as a duplicate of 194597 ***

Note You need to log in before you can comment on or make changes to this bug.