Bug 19745 - gview problem with vncviewer
Summary: gview problem with vncviewer
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ghostscript   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Dale Lovelace
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-25 12:06 UTC by Jean-Yves Toumit
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-18 23:03:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jean-Yves Toumit 2000-10-25 12:06:17 UTC
Config:
a machine with RedHat 7, vncserver running.
connecting from a windows 2000 machine with vncviewer. My current window
manager is sawfish.

Error:
Ghostview can't read ps files from vncviewer and says:
Error: PostScript interpreter failed in main window.

Fix:
Upgrading ghostscript to 5.50-10 doesn't change anything but forcing the
upgrade of gv and gs to gv-3.5.8-180 and gs_x11-5.50-38 fixes it all
(xshared-3.3.6-47 and gs-lib, gs-fonts also).
On the other hand, on the RedHat machine itself, everything was normal
before the upgrade, the problem occurred only through vncviewer so it must
be a rather weird bug (maybe upgrading vnc could have fixed it also?).
JY.

Comment 1 Bill Nottingham 2000-11-13 06:08:26 UTC
I'm not sure I understand you here; you say you forced the upgrade
of packages, but the packages you mention aren't Red Hat package
names.

Did you have the font server running on the machine running
vncserver?

Comment 2 Jean-Yves Toumit 2000-11-13 09:32:42 UTC
Hello again.
Well, actually, I went on my favorite web site with tons of rpms, downloaded 
the packages and forced their installation with "rpm -ivh --force".
These aren't RedHat packages (sorry), I know that, but they were the most up-to-
date when I downloaded them.
As for the font server on the machine running vncserver, I simply can't be sure 
now, as so many things have already changed on my machine... :-) But I guess 
this can't be the problem because it has disappeared with the new packages I've 
downloaded.
I'll have to check at home with my other machine on which I haven't upgraded 
the packages.
JY.

Comment 3 Bill Nottingham 2001-06-11 15:27:16 UTC
ghostscript is coredumping. This seems to happen in 7.1 too. Assigning to
ghostscript.

Comment 4 Tim Waugh 2001-12-19 12:51:45 UTC
I can't reproduce this under Red Hat Linux 7.2.



Note You need to log in before you can comment on or make changes to this bug.