Bug 1974729 - Update cinderlib installation instructions
Summary: Update cinderlib installation instructions
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation
Version: 4.4.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.4.9
: ---
Assignee: Donna DaCosta
QA Contact: Pavol Brilla
URL:
Whiteboard:
Depends On: 1955375
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-06-22 12:10 UTC by Benny Zlotnik
Modified: 2021-11-16 22:03 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Release Note
Doc Text:
new channels need to be enabled prior to upgrading engine and hosts.
Clone Of:
Environment:
Last Closed: 2021-11-16 22:03:53 UTC
oVirt Team: Docs
Target Upstream Version:
bzlotnik: needinfo-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1955375 1 unspecified CLOSED [cinderlib] Provide cinderlib prerequisites in host and engine installation 2021-08-25 17:49:50 UTC

Internal Links: 1997666

Description Benny Zlotnik 2021-06-22 12:10:26 UTC
Description of problem:
Once bug 1955375 is ready, the manual steps for installation should become redundant. That is, python3-cinderlib and ceph-common would be installed automatically on the ovirt-engine machine, as well as python3-os-brick and ceph-common on the Vdsm hosts

Also openstack 16.2 should be used instead:
the change required is:
# subscription-manager repos --enable=openstack-16.1-cinderlib-for-rhel-8-x86_64-rpms
to
# subscription-manager repos --enable=openstack-16.2-cinderlib-for-rhel-8-x86_64-rpms

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Pavol Brilla 2021-08-25 14:05:37 UTC
Bug 1955375 is for upstream, but we are not having those packages in errata to be included in our repositories ....

Downstream we have only Appendix C where we document Installation of Ceph:
https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.4/html/installing_red_hat_virtualization_as_a_standalone_manager_with_local_databases/set_up_cinderlib 

I am raising this because current candidate in errata tools is failing as it requires ceph-common on host to be installed:

error: Failed dependencies:
ceph-common is needed by ovirt-host-dependencies-4.4.8-1.el8ev.x86_64

ceph-common + its deps are not in any of our channels nor they are in errata tool to be shipped

Comment 3 Marina Kalinin 2021-09-22 02:18:39 UTC
I believe first of all we should fix this bz#1997666 on the subject, with much higher priority. 
Cause current instructions are incorrect, as bz#1997666 explains.

Comment 6 Pavol Brilla 2021-10-27 10:13:01 UTC
doc pull request on github looks good to me

Comment 8 Donna DaCosta 2021-11-16 22:03:53 UTC
Changes published.


Note You need to log in before you can comment on or make changes to this bug.