Bug 197501 - wxGTK-devel should Require: libGLU-devel
wxGTK-devel should Require: libGLU-devel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: wxGTK (Show other bugs)
5
All Linux
medium Severity low
: ---
: ---
Assigned To: Matthew Miller
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 193531
  Show dependency treegraph
 
Reported: 2006-07-03 07:56 EDT by Paul Howarth
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.3-2.6.3.2.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-03 11:58:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul Howarth 2006-07-03 07:56:48 EDT
Line 25 of /usr/include/wx-2.6/wx/gtk/glcanvas.h in the wxGTK-devel package is:

#include <GL/glu.h>

This is pulling in a header file from libGLU-devel, hence it should be a
dependency of wxGTK-devel.

It also pulls in headers from libGL-devel, but since libGL-devel is itself a
dependency of libGLU-devel, libGL-devel will not be an issue if a libGLU-devel
dependency is added.
Comment 1 Matthew Miller 2006-07-03 09:04:34 EDT
Okay. Will add this next time I update.
Comment 2 Paul Howarth 2006-07-03 09:08:35 EDT
OK, but please bear in mind that packages using this are having to work around
the problem by buildrequiring libGLU-devel themselves at the moment (e.g. see
Bug #193531).
Comment 3 Matthew Miller 2006-07-03 09:09:42 EDT
*nod*
Comment 4 Matthew Miller 2006-07-03 11:58:08 EDT
Okay, since this was so trivial I just went ahead and did it. The update is
building now.

Note You need to log in before you can comment on or make changes to this bug.