Bug 197518 - Using a relative path to the disk image mysteriously fails
Using a relative path to the disk image mysteriously fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-03 11:09 EDT by Mark McLoughlin
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-03 23:25:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xenguest-install-abspath.patch (301 bytes, patch)
2006-07-03 11:09 EDT, Mark McLoughlin
no flags Details | Diff

  None (edit)
Description Mark McLoughlin 2006-07-03 11:09:02 EDT
Created attachment 131884 [details]
xenguest-install-abspath.patch
Comment 1 Mark McLoughlin 2006-07-03 11:09:02 EDT
When doing:

  $> xenguest-install.py -f foo.img

things seem to work fine (e.g. the image gets created if it doesn't exit) except
the device isn't actually exported to the guest.

Problem turns out to be that Xen needs an absolute path.

Attached is a simple patch to make any relative paths absolute.
Comment 2 Jeremy Katz 2006-07-03 23:25:53 EDT
Committed the fix and building it

Note You need to log in before you can comment on or make changes to this bug.