Bug 197540 - Hotkeys / Gnome key bindings must be reset for them to work in Rhythmbox
Hotkeys / Gnome key bindings must be reset for them to work in Rhythmbox
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
: Reopened
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-07-03 18:36 EDT by Stewart Adam
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-01 17:56:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stewart Adam 2006-07-03 18:36:47 EDT
Description of problem:
Hotkeys or the key bindings set with gnome-keybinding-properties must be
constantly reset each Gnome session for the Rhythmbox player to pick it up

Version-Release number of selected component (if applicable):
rhythmbox-0.9.5-1 (but I think 0.9.4, too)

How reproducible:
Always

Steps to Reproduce:
1. Set your key binding
2. Restart rhythmbox, test if they work. They should.
3. Logout, log back in.
4. Start rhythmbox, and they hotkeys don't work. Check the gnome settings,
they're still set.
5. Re-configure your key settings, and restart rhythmbox
6. They'll work again.
  
Actual results:
The Gnome key bindings must be reset every time for Rhythmbox to pick them up

Expected results:
For Rhythmbox to 'remember' properly and use the same hotkeys when you log back in.

Additional info:
I know it's something to do with rhythmbox because the same keys that I tried to
use for Rhythmbox are working correctly upon re-login if they're set to volume
controls.
Comment 1 Matthias Clasen 2006-07-28 23:34:45 EDT
This works fine here. 
Maybe some other application is stealing your keys, like totem or beagle-search ?
Comment 2 Stewart Adam 2006-08-02 14:43:55 EDT
Nope, no chance there as they're my multimedia keys. I've manually set them with
'setkeycodes'. I also, just to make sure the bug was valid, tried with crazy
combos like < ctrl alt shift 5 > but it still didn't work. I'll try again
though, it's been 2 rhythmnox updates since I created this bug.
Stewart
Comment 3 Stewart Adam 2006-09-03 14:02:51 EDT
Nope, still happening in rhythmbox-0.9.5-2.
Comment 4 Stewart Adam 2006-09-14 19:54:55 EDT
It seems now that with the rhythmbox I list above and the new Gnome 2.16 even
restarting Rhythmbox doesn't help it "realize" the new keys, and it's not a
Gnome bug because for example I can change the 'Eject' function to the key I
(try to) use for "Next" and it works right away.

I noticed this is on the FC6Target - We're only a month or so away from the
final and it's not assigned yet - Is this because of lack of information? I can
try doing traces if it's needed.
Comment 5 Stewart Adam 2006-09-14 19:55:35 EDT
** Edit: I just noticed that it is indeed assigned to Monty - Shouldn't the bug
status be "ASSIGNED" then?
Comment 6 Matthias Clasen 2006-09-14 21:58:54 EDT
It does not work currently because Ray took out the key grabbing from
gnome-settings-daemon, and will add it to the multimedia apps instead.
I expect him to get back to this soon.
Comment 7 Stewart Adam 2006-10-08 15:21:32 EDT
FC6 is due the 17th - Do you thing Ray will add them back in before then?
Comment 8 Rudi Chiarito 2006-11-01 08:15:24 EST
Still not working. Used to work with FC5. Should the bug be reassigned to Ray, too?
Comment 9 Alexander Larsson 2006-11-21 04:59:57 EST
Ray, i'm giving this to you since you seem to be working on the key bindings stuff
Comment 10 Ray Strode [halfline] 2006-11-21 15:03:58 EST
So the keybinding code is back in control-center (with the restriction that you
can only use it with keys that seem like they're multimedia keys).  The
rhythmbox in tomorrow's rawhide reverts back to depending on control-center to
assign the multimedia keys.

Rudi, can you try the control-center and rhythmbox from rawhide and see if they
fix your problem?  If you're not running rawhide I can push things to
updates-testing
Comment 11 Stewart Adam 2006-11-21 16:28:32 EST
I'll check tomorrow and post back ASAP. I'm currently running rawhide so
everything should work out OK.
Comment 12 Stewart Adam 2006-11-23 11:37:23 EST
Seems to work for me now...
Comment 13 Stewart Adam 2006-11-24 08:33:19 EST
I'm sorry for the mistake, I forgot to logout and check if they still work -
This morning when I logged in again the hotkeys didn't work.
Comment 14 Stewart Adam 2006-11-27 19:47:05 EST
This is odd - This time they work. Two times it didn't, it does now, I'll come
back to let you know what happens the next time I log on.
Comment 15 Stewart Adam 2007-01-28 12:52:36 EST
Not working anymore with :
control-center-2.17.90-2.fc7
rhythmbox-0.9.7-6.fc7
Comment 16 Bastien Nocera 2007-01-30 11:18:55 EST
(In reply to comment #15)
> Not working anymore with :
> control-center-2.17.90-2.fc7
> rhythmbox-0.9.7-6.fc7

Recent control-centers use D-Bus to push the multimedia keys to the
applications, rather than set the keysyms. Rhythmbox hasn't been updated for
that just yet[1]

Are your keys mapped using the control-center, or "by hand"? Could you please
double-check whether "xev" shows the right keysym for those keys?


[1]: see http://bugzilla.gnome.org/show_bug.cgi?id=398184
Comment 17 Stewart Adam 2007-01-30 17:34:53 EST
I'm currently using a 'Generic 105 key' keyboard layout, no keys set by hand.
xev shows the keys (I have three) being pressed but keysym is 0x0... Although
Gnome shows the keysyms fine, they are or similar to something like 0x90a.
Either way, it works for other bindings such as Eject, so I doubt that's the issue.
Comment 18 Bastien Nocera 2007-01-30 18:17:45 EST
Yeah, that's definitely the above problem. The old multimedia keys code was
completely busted (I wrote it myself, but the way of doing things changed and we
ended up with a broken system[1]), so it has now changed to using D-Bus to push
the key events to the media players.

I'll do a build with the upstream patch as soon as I can, it should fix your
particular problem.

[1]: ACME used to handle only keycodes, when we merged it in the GNOME
control-center, we started handling keys with keysyms, and it completely broke
some assumptions that were made in the code.
Comment 19 Bastien Nocera 2007-01-31 12:19:01 EST
Should be fixed in rhythmbox-0.9.7-11.fc7, let me know if it fixes it for you.
Comment 20 Stewart Adam 2007-02-01 17:56:10 EST
Works again.

Note You need to log in before you can comment on or make changes to this bug.