Bug 197563 - Samba over nfs troubles, hangs Windows clients
Samba over nfs troubles, hangs Windows clients
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: nfs-utils (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Layton
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2006-07-04 02:12 EDT by Rainer Traut
Modified: 2008-01-15 06:41 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-01-15 06:41:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Rainer Traut 2006-07-04 02:12:50 EDT
Description of problem:
Samba over nfs troubles, it hangs Windows clients as soon as I try to open files
via Samba which in turn reside on NFS.
I have tried the same on FC5 and there it works.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. NFS export:

2. mount it: /srv/samba/nfs nfs rw,sync 0 0 

3. make a samba share and mount it via Windows:
        path = /srv/samba
        writable = yes
        valid users = tr 
Actual results:
As soon as I start to read and write files below
/srv/samba/nfs via Samba on Windows the connection hangs, I get read timeout in

Expected results:
Read and write fine

Additional info:
NFS is functional, I can read/write in /srv/samba/nfs as user tr
and see the changes in /srv/nfsexp.

Samba is functional, I can read/write with windows in /srv/samba but
not in /srv/samba/nfs.
I played with variuos nfs export options as well as samba locking options,
always the same problem.
Comment 1 Rainer Traut 2006-07-05 04:54:51 EDT
An additional note: this is just a simple test case, reproducing the problem 
with just one host involved to keep the configuration as simple as possible.
The same happens if NFS is mounted on a different host and the samba share is 
exported there.
Comment 2 Jeff Layton 2007-07-20 15:22:52 EDT
In regards to comment #1, in order to reproduce this, which host needs to be
RHEL4? Does this problem reproduce when the NFS server is RHEL4, the NFS client
is RHEL4, or only when both are on RHEL4? You mentioned that it worked with FC5,
which piece did you replace with a FC5 machine when you discovered this?

Comment 3 starlight 2007-09-26 11:48:36 EDT
Just hit this same problem.  It happens only when NFSv4
mounts are active.  Just switched from NFSv3 to NFSv4 mounts
and now an application that reads a huge file over a Samba
share locks up on read requests.  Sometimes stop/start cycling
Samba helps but the most reliable fix is to put the NFS shares
back to NFSv3 and reboot.

Here are some messages related to the hang.

Sep 26 11:14:24 keira smbd[18850]: [2007/09/26 11:14:24, 0]
Sep 26 11:14:24 keira smbd[18850]:   getpeername failed. Error was Transport
endpoint is not connected 
Sep 26 11:14:24 keira smbd[18850]: [2007/09/26 11:14:24, 0]
Sep 26 11:14:24 keira smbd[18850]:   write_socket_data: write failure. Error =
Connection reset by peer 
Sep 26 11:14:24 keira smbd[18850]: [2007/09/26 11:14:24, 0]
Sep 26 11:14:24 keira smbd[18850]:   write_socket: Error writing 4 bytes to
socket 5: ERRNO = Connection reset by peer 
Sep 26 11:14:24 keira smbd[18850]: [2007/09/26 11:14:24, 0]
Sep 26 11:14:24 keira smbd[18850]:   Error writing 4 bytes to client. -1.
(Connection reset by peer) 
Comment 4 starlight 2007-09-26 13:03:19 EDT
Wait!  I apologize as I attributed the incorrect cause to the
effect.  Now I see the problem happens with the NFSv3 mounts
active, or with *no* NFS mounts active.

The more I dig the stranger this gets, so it's probably nothing
to do with this issue.  Sorry.
Comment 5 Jeff Layton 2008-01-15 06:41:01 EST
No response from the original reporter for several months. Closing with
resolution of INSUFFICIENT_DATA. Please reopen if you're still able to reproduce
this and can provide the info requested.

Note You need to log in before you can comment on or make changes to this bug.