Bug 197580 - Installation doesn't work on s390 (using hercules)
Installation doesn't work on s390 (using hercules)
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
Blocks: 200020
  Show dependency treegraph
Reported: 2006-07-04 06:22 EDT by Matthias Saou
Modified: 2008-06-04 15:36 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-06-04 15:36:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Matthias Saou 2006-07-04 06:22:52 EDT
The current FC development tree for s390 doesn't seem to install using hercules.
Using the exact same hercules configuration, I can install Red Hat Linux 7.2 for
s390 fine.

Steps to reproduce :
- Install the hercules-3.04.1-2.fc6 Extras package
- Follow the instructions containeed in README.fedora

Result :
5 identical lines, and hercules taking all CPU :
request_module: runaway loop modprobe char-major-4-1
request_module: runaway loop modprobe char-major-4-1
request_module: runaway loop modprobe char-major-4-1
request_module: runaway loop modprobe char-major-4-1
request_module: runaway loop modprobe char-major-4-1

This is apparently tty1, but with the same hercules configuration the RHL7.2
console appears fine (root prompt).
Comment 1 Karsten Hopp 2006-07-04 07:30:38 EDT
doesn't work on 'real' hardware either. tested with rawhide-20060703/s390.
Comment 2 Karsten Hopp 2006-07-04 07:35:18 EDT
s390 and s390x both fail with these messages
Comment 3 Matthias Saou 2006-07-04 12:19:19 EDT
FWIW, I've just tried an installation of RHEL4u3 and right after :

 Select which protocol should be used for the CTC interface
 0 for compatibility with p.e. VM TCP service machine (default)
 1 for enhanced package checking for Linux peers
 3 for compatibility with OS/390 or z/OS peers

which is when the above runaway loop appears, it continues fine with :

 CTC driver Version: 1.63  initialized
 divert: not allocating divert_blk for non-ethernet device ctc0
 ctc0: read: ch-0.0.0600, write: ch-0.0.0601, proto: 1
 Enter your DNS server(s), separated by colons (:):
 Enter your DNS search domain(s) (if any), separated by colons (:):

not sure what code runs right before the ctc device initialization, but that's
where it fails.
Comment 5 Bill Nottingham 2006-07-05 14:05:19 EDT
Punting to kernel for now.
Comment 6 Karsten Hopp 2006-07-24 11:17:47 EDT
Jan, any news here ? This still happens with 2.6.17-1.2432.el5.s390x 
Comment 8 Jan Glauber 2006-07-25 07:48:13 EDT
An error like: "request_module: runaway loop modprobe"
usually means that it was tried to load a 32 bit module
under a 64 bit kernel or a 64 bit module in a 64 bit kernel.

Can you check if kernel and modules fit together?

I will try to recreate the problem, but the installation will
take me some time...
Comment 9 Bug Zapper 2008-04-03 13:31:34 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 10 Jarod Wilson 2008-04-10 11:41:51 EDT
FWIW, RHEL4.6 s390x installs just fine under current rawhide x86_64 hercules.
Will put trying RHEL5 s390x on the TODO list...
Comment 11 Bug Zapper 2008-05-13 22:11:30 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
Comment 12 Dave Jones 2008-06-04 15:36:38 EDT
Given we're not doing builds for s390 in Fedora right now, keeping two year old
bugs open seems pointless with the amount of change that occurs upstream.

Note You need to log in before you can comment on or make changes to this bug.