Bug 197593 - FC devel net install fails when falling back to text mode
FC devel net install fails when falling back to text mode
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2006-07-04 08:54 EDT by Matthias Saou
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-07-05 12:06:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Matthias Saou 2006-07-04 08:54:28 EDT
I've been trying to install FC devel through FTP for a few days now. With the
20060703 i386 boot.iso, I :
- Booted with "linux noipv6"
- Chose English, French keyboard
- Chose FTP install
- Left DHCP configuration (I did see messages about eth0 not having any link
after it successfully got its IP info!)
- Entered location info
- Saw anaconda start, video detection work...

But then I saw some "Install exited abnormally [1/1]" message, and on tty8 :

/usr/bin/python: symbol lookup error: /mnt/runtime/usr/lib/libunicode-lite.so.1:
undefined symbol: wlite_mbrtowc

The only libunicode-lite.so.1 I can find on a normal FC system comes from
anaconda-runtime, so I'm guessing this is more install/anaconda related than it
is python related, although I could be wrong, in which case please reassign to
the right person.
Comment 1 G.Wolfe Woodbury 2006-07-04 23:07:06 EDT
I solved this problem by inserting a floppy disk into the floppy drive!

I was getting the same sort of errors and saw an anaconda message about floppy
and fd0. Wondering if it was looking for a place to dump the error log
automagically, I inserted a blankable floppy in the drive before trying the
install again.

It is now working.
Comment 2 Matthias Saou 2006-07-05 04:33:14 EDT
For me, adding a floppy doesn't solve the problem.

Now I do have a line "INFO : anaconda floppy device fd0" right before the last
line, which is "WARNING : Graphical installation not available... Starting text
mode." (which is because I have only allocated 128MB RAM to qemu). But I still
got the same problem.

So I tried allocating 512M RAM to qemu... and the graphical insstallation works!
The bug seems to only appear when falling back (or maybe defaulting too) to text
mode install.
Note also that I don't see the python error on tty8 when installing in graphical
mode, so is it likely to be related to the problem.
Comment 3 Jeremy Katz 2006-07-05 12:06:41 EDT
Yeah, it's a result of falling back to minstg2.img where we use a stub for some
stuff in glibc... should be fixed in CVS

Note You need to log in before you can comment on or make changes to this bug.