Bug 197603 - yum.conf: debuglevel
yum.conf: debuglevel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-04 10:37 EDT by Florian La Roche
Modified: 2014-01-21 17:54 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-05 12:11:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Use self.conf instead of self.startupconf (803 bytes, patch)
2006-07-05 10:13 EDT, James Bowes
no flags Details | Diff

  None (edit)
Description Florian La Roche 2006-07-04 10:37:38 EDT
Description of problem:

If an older yum.conf is present which used to support "debuglevel", then
yum-2.9.2 is giving a traceback. Maybe that setting should be silently
ignored or with a warning that is doesn't have any effect.


Version-Release number of selected component (if applicable):


How reproducible:
Add "debuglevel=2" to /etc/yum.conf.



Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Florian La Roche 2006-07-04 10:52:42 EDT
This actually seems to happen due to "yum -d 1" and not due to the config
settings. cli.py line 196 does not have a self.startupconf:

        if opts.debuglevel is not None:
            self.startupconf.debuglevel = opts.debuglevel
        if opts.errorlevel is not None:
            self.startupconf.errorlevel = opts.errorlevel
Comment 2 James Bowes 2006-07-05 10:13:00 EDT
Created attachment 131928 [details]
Use self.conf instead of self.startupconf

Looks like things got out of sync with the logging patch and some changes to
the config parsing/loading. This patch should fix that up.
Comment 3 Jeremy Katz 2006-07-05 12:11:54 EDT
Committed upstream and in yum-2.9.2-3

Note You need to log in before you can comment on or make changes to this bug.