Bug 1976284 - [Azure] While mirroring images to private registry throwing error: invalid character '<' looking for beginning of value
Summary: [Azure] While mirroring images to private registry throwing error: invalid ch...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.7
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.7.z
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
: 1970458 (view as bug list)
Depends On: 1946839
Blocks: 1976285
TreeView+ depends on / blocked
 
Reported: 2021-06-25 16:55 UTC by Maciej Szulik
Modified: 2021-09-30 08:47 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: During mirroring we create an authorization header with all the image information. Consequence: Some registries have limits on header size which are violated by the size. Fix: Force --skip-multiple-scopes for oc adm catalog mirror command. Result: Mirroring works as expected.
Clone Of: 1946839
: 1976285 (view as bug list)
Environment:
Last Closed: 2021-07-06 11:38:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift oc pull 869 0 None open [release-4.7] Bug 1976284: skip-multiple-scopes with adm catalog mirror 2021-06-25 16:58:22 UTC
Red Hat Product Errata RHBA-2021:2554 0 None None None 2021-07-06 11:39:04 UTC

Comment 4 zhou ying 2021-07-01 08:38:31 UTC
can't reproduce with latest oc client:
[jzhang@dhcp-140-36 ~]$ ./oc version --client
Client Version: 4.7.0-0.nightly-2021-07-01-021451
[jzhang@dhcp-140-36 ~]$ ./oc adm catalog mirror  quay.io/openshift-qe-optional-operators/ocp4-index:latest quay.io/olmqe
src image has index label for database path: /database/index.db
using database path mapping: /database/index.db:/tmp/021158519
wrote database to /tmp/021158519
using database at: /tmp/021158519/index.db
quay.io/
  olmqe/amq7-amq-streams-bridge-rhel7
    blobs:
      registry.redhat.io/amq7/amq-streams-bridge-rhel7 sha256:57584b59d88badb977c5077949af3d65f9b9f864d1c9f295a97aed0ab555e865 1.645KiB
      registry.redhat.io/amq7/amq-streams-bridge-rhel7 sha256:0dc69daaa449d5bb3174c603b31b9cb51e446f8b8bb4f0604c12dfbd7e587536 1.771KiB
      registry.redhat.io/amq7/amq-streams-bridge-rhel7 sha256:2814fe1cf24ff0dff937f2fa98bfb5e1607a091eaed8821d08fadb46d2e4fa15 1.856KiB
....

uploading: quay.io/olmqe/openshift4-ose-kube-rbac-proxy sha256:c7fc28264eb57e585d882b48fd430b227017858345b62c18c4fa0417cc6b03f1 15.35MiB
uploading: quay.io/olmqe/openshift4-ose-kube-rbac-proxy sha256:d40fbc59c975a5b2679c4159a6671d4f96dfd9c684cf4401aa27f301b8f4670b 39.83MiB
uploading: quay.io/olmqe/openshift4-ose-kube-rbac-proxy sha256:0fce82565dd7f1597f3f063aada10fc1ec363e24ba671eb903c69577894e94b4 15.18MiB
uploading: quay.io/olmqe/openshift4-ose-kube-rbac-proxy sha256:4913d6af3405932328469181492ce21b933fc432451ca4ee1ef5cf112703dbc7 10.99MiB

Comment 5 zhou ying 2021-07-01 08:50:05 UTC
[jzhang@dhcp-140-36 ~]$ ./oc version --client -o yaml 
clientVersion:
  buildDate: "2021-06-25T21:59:29Z"
  compiler: gc
  gitCommit: 8b4b09487463415374368af3bbc4ff2e6366477b
  gitTreeState: clean
  gitVersion: 4.7.0-202106252127.p0.git.8b4b094-8b4b094
  goVersion: go1.15.7
  major: ""
  minor: ""
  platform: linux/amd64
releaseClientVersion: 4.7.0-0.nightly-2021-06-26-014854



[root@localhost ~]# ./oc version --client -o yaml 
clientVersion:
  buildDate: "2021-06-30T05:26:58Z"
  compiler: gc
  gitCommit: 8b4b09487463415374368af3bbc4ff2e6366477b
  gitTreeState: clean
  gitVersion: 4.7.0-202106300359.p0.git.8b4b094-8b4b094
  goVersion: go1.15.7
  major: ""
  minor: ""
  platform: linux/amd64
releaseClientVersion: 4.7.0-0.nightly-2021-07-01-021451

Comment 7 errata-xmlrpc 2021-07-06 11:38:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.19 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:2554

Comment 8 Maciej Szulik 2021-09-30 08:47:52 UTC
*** Bug 1970458 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.