Bug 197640 - Mesa isn't getting built with optimizations
Mesa isn't getting built with optimizations
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-05 03:09 EDT by Nicholas Miell
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-21 16:52:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix OPT_FLAGS usage (1020 bytes, patch)
2006-07-05 03:20 EDT, Nicholas Miell
no flags Details | Diff

  None (edit)
Description Nicholas Miell 2006-07-05 03:09:30 EDT
I've opened this bug as instructed in
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=193979#c3

The spec changes to pass RPM_OPT_FLAGS in to the Mesa build via OPT_FLAGS aren't
sufficient -- the linux, linux-dri, and linux-dri-ppc Makefile fragments clobber
the OPT_FLAGS variable in a fashion similar to the already-fixed ARCH_FLAGS.

The OPT_FLAGS assignments in those files needs to be changed to a conditional
assignment or an appending assignment, depending on what you think it should do.
(Probably a conditional assignment, the PPC config selects a specific -mtune
option and I'm not sure how gcc will react to multiple conflicting -mtune options.)
Comment 1 Nicholas Miell 2006-07-05 03:20:22 EDT
Created attachment 131914 [details]
fix OPT_FLAGS usage

stick this in as Patch2, or just combine it with Patch0 and Patch1 into a new
all-devouring superpatch
Comment 2 Mike A. Harris 2006-07-05 04:36:44 EDT
Looks right to me.  Applied to -13.fc6 along with a fix to the problem you
mentioned in IRC (before getting timed out):

<DrNick> woo! /usr/lib64/dri got the wrong perms

* Wed Jul 05 2006 Mike A. Harris <mharris@redhat.com> 6.5-13.fc6
- Added mesa-6.5-fix-opt-flags-bug197640.patch as 2nd attempt to fix OPT_FLAGS
  for (#197640).
- Ensure that redhat-mesa-driver-install creates $DRIMODULE_DESTDIR with
  mode 0755.
Comment 3 Mike A. Harris 2006-07-05 04:45:47 EDT
Unfortunately, due to bug #195980 I am unable to build the newly fixed
mesa package, however I will build it once releng has rectified the
problem with the buildsystem.
Comment 4 Mike A. Harris 2006-07-21 16:52:11 EDT
Built this a long time ago.  Current is mesa-6.5-13.1.fc6

Note You need to log in before you can comment on or make changes to this bug.