Bug 1976768 - Inquiries regarding missing data in the calendar table created/inserted into the ovirt_engine_history DB.
Summary: Inquiries regarding missing data in the calendar table created/inserted into ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine-dwh
Classification: oVirt
Component: Database
Version: 4.4.7.2
Hardware: Unspecified
OS: All
high
high vote
Target Milestone: ovirt-4.4.7
: 4.4.7.3
Assignee: Aviv Litman
QA Contact: Pavel Novotny
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-06-28 08:06 UTC by jmh
Modified: 2021-07-08 14:15 UTC (History)
7 users (show)

Fixed In Version: ovirt-engine-dwh-4.4.7.3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-08 14:15:41 UTC
oVirt Team: Metrics
pm-rhel: ovirt-4.4+
mperina: blocker?
pelauter: planning_ack+
sradco: devel_ack+
lsvaty: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 115471 0 master MERGED Fixing year in the calendar table 2021-07-01 07:02:34 UTC

Description jmh 2021-06-28 08:06:43 UTC
Description of problem:

I recently discovered that the spark-line chart is not displayed in the dashboard of the ovirt admin page. As a result of looking up the code and query, the data of the calendar table in the ovirt_engine_history DB of ovirt-dwh was only available until 2021-01-01 00:00:00, so a query statement ( https://github.com/oVirt/ovirt-engine/blob/master/frontend/webadmin/modules/frontend/src/main/resources/org/ovirt/engine/ui/frontend/server/dashboard/dao/HostDwhDAO.properties)RIGHT OUTER JOIN was not getting the correct data. First, the existing "generate_series('2011-01-01 00:00'::timestamp, '2021-01-01 00:00', '1 hours')" part was temporarily modified and applied until 2051. , it was confirmed that the spark-line chart was displayed normally.


Version-Release number of selected component (if applicable):


How reproducible:

https://github.com/oVirt/ovirt-dwh/blob/master/packaging/dbscripts/upgrade/03_05_0060_updated_insert_calendar_table_values_script.sql

Please modify the sql file so that spark-line chart is output without any problem in Dashboard.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 RHEL Program Management 2021-06-28 11:37:48 UTC
The documentation text flag should only be set after 'doc text' field is provided. Please provide the documentation text and set the flag to '?' again.

Comment 2 Martin Perina 2021-06-29 09:42:54 UTC
Data present in webadmin dashboard might be incorrect, but we don't loose anything. After fixing the calendar table, dashboard should be working again

Comment 5 Pavel Novotny 2021-07-08 13:41:00 UTC
Verified in 
ovirt-engine-4.4.7.6-0.11.el8ev.noarch
ovirt-engine-dwh-4.4.7.3-1.el8ev.noarch

The sparkline chart is visible again and it's showing correct data.

Comment 6 Sandro Bonazzola 2021-07-08 14:15:41 UTC
This bugzilla is included in oVirt 4.4.7 release, published on July 6th 2021.

Since the problem described in this bug report should be resolved in oVirt 4.4.7 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.